#94 setup.py: Move the requirements from requires to install_requires

4.1-updates
closed
2013-11-12
2013-08-18
No

The required packages are not installed automatically on the ReText installation. The packages to install should reside in the install_requires section, not in the requires section.

Discussion

  • Thanks for reporting this.

    Perhaps PyQt should not be listed in install_requires (as it is a binary extension and needs to be compiled)?

    Also, I'm still playing with PyPI and haven't yet tested installation from there. Do you use pip or easy_install?

    Finally, I'm not very happy with:

    /usr/lib/python3.3/distutils/dist.py:257: UserWarning: Unknown distribution option: 'install_requires'
      warnings.warn(msg)
    
     
  • I am using pip.

    Also, it's quite weird you have this warning. See some repos by Kenneth Reitz or bitbucket.org/moigagoo/sloth. This option is widely used and defines the actual list of packages to be installed.

     
    • status: open --> closed
    • assigned_to: Dmitry Shachnev
    • Milestone: retext-next --> 4.1-updates
     
  • Fixed in 4.1.1, please test the change and give your feedback.

     

  • Anonymous
    2013-11-11

    Cannot install 4.1.1 under Python 3.

    Installs but fails to launch under Python 2.

     
    • Cannot install 4.1.1 under Python 3.

      What's the error message?

       
  • I am sorry for not posting the entire backtrace at first and posting a comment as anonymous.

    Here's the Python 3 installation backtrace: http://pastebin.kde.org/p153e784d

    Under Python 2, PyQt or PySide seem to be not declared as installation dependencies: http://paste.kde.org/p007281ff

     
      1. That looks like an issue with Enchant or distribute_setup. The only thing I can do about it is to remove enchant from the list.

      2. ReText 4.1 doesn't support Python 2.

      3. PyQt/PySide aren't installable from PyPI, as they are written in C++.

       

      • Anonymous
        2013-11-12

        1. Strangely, it installs with py2 but fails with py3. But OK, thanks for the info (I prefer Python 3 myself).

        2. Yes, they are:

        https://pypi.python.org/pypi/PySide/1.2.1
        https://pypi.python.org/pypi/PyQt4/4.10.3
        https://pypi.python.org/pypi/PyQt5/5.1.1

         
        • PyQt doesn't even have any tarballs on PyPi. PySide does, but still I think it can't be built using pip only.

           


Anonymous


Cancel   Add attachments