RC with VSTO is finally OUT :)

2006-04-04
2013-05-01
  • Daniele Tiles
    Daniele Tiles
    2006-04-04

    Hi,
    alright...Did you have problems loading RC? Did it get installed but it didn't work? Couldn't you see anything? The installer didn't work?

    Now it's online the final solution to your problem! RC has been finally compiled using the new Visual Studio Tools for Office. This new developing environment helps also the deploying of the AddIn, by solving every security, COM/.NET problem.
    It requires NECESSARY:
    -- the .NET framework 2
    -- the VSTO runtime environment (this 2 items should be installed by the installer itself)

    Unless I'll receive some precise motives about keeping a build for RC working with the .NET framework 1.1, I'll stop supporting. This, because there are many security and loading concerns which are too complicated to be solved without VSTO.

    Please, try it and let me know :)
    Bye

    lasthope83

     
    • Daniele Tiles
      Daniele Tiles
      2006-04-04

      Just remember: this installer WON'T uninstall any previuos version you've got of RC!!

       
    • BenJG
      BenJG
      2006-04-04

      Hi lasthope83,

      First again, thanks for your great work. Unfortunately, installation doesn't work:
      I deinstalled the old version, downloaded the ...4.72VSTO-file and tried to install it. After the message that VSTO runtime is missing and has to be installed first, the routine stops: "The installer was interrupted before RC could be installed. Restart the installer ...". Have I missed anything?

      Best, Ben

       
    • BenJG
      BenJG
      2006-04-04

      Hi,
      sorry - I misread your message: With "installer" you meant the user, not the installer-routine. Thus the VSTO was not included within the installer. Now I have installed net-2.0, vsto-runtime and rc and it is running well!

      Cheers, Ben

       
      • Daniele Tiles
        Daniele Tiles
        2006-04-04

        That's....AWESOME!! :D
        Thank you for using RC ;)
        Bye

        lasthope83

         
    • Daniele Tiles
      Daniele Tiles
      2006-04-04

      Unfortunately, I've to add some bad news: there are some cases in which RC may not work:
      http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=223585&SiteID=1
      Take a look to the 8th question :(
      Bye

      lasthope83

       
    • Daniele Tiles
      Daniele Tiles
      2006-04-05

      Hi,
      I've discovered that the msi will check for any prerequisites, but it WON'T install any missing.
      I've uploaded another version of the setup:
      http://prdownloads.sourceforge.net/remotecalendars/RemoteCalendarsVSTOSetup-4.72.exe?download
      I'm not sure if there are any other differences...however, if the setup didn't work, I would strongly recommend to use this last file.
      Bye

      lasthope83

       
    • JJ Saenz
      JJ Saenz
      2006-04-05

      Thanks for writing ths program... for me it is very important in order to link my Basecamp projects with Outlook. BUT:

      1. The installer didn't work. Went and downloaded the VSTO runtime with the link above... installed sucessfully (according to the installer) but still I don't have a toolbar with the RemoteCalendars buttons! (my Outlook is in Spanish... is that a problem?)
      2. The installer forgot to remind me to close utlook while installing - had to install twice.
      3. I couldn't tell you any of this in your remotecalendars blog because I do not have a Blogger account... you should change that and allow people to comment without having an account (Blogger has that option).
      4. I couldn't subscribe to the remotecalendars updates mailing list, the confirmation email bounced.

      Anyway, thanks a lot for writing this and I hope I can get it to work!

       
      • Daniele Tiles
        Daniele Tiles
        2006-04-05

        Hi there,
        1) No, it shouldn't be a problem, but it seems there are still some compatibility problems if you've got other plugins installed (like NewsGator as told here:
        http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=223585&SiteID=1\)
        However, could you try to use this installer?
        http://prdownloads.sourceforge.net/remotecalendars/RemoteCalendarsVSTOSetup-4.72.exe?download
        This installer should be smarter...
        However, I'd like you to tell me what you can find by doing this:
        --If you open Outlook, click: Options --> tab Other --> Advanced
        Options --> Additional COM components. Do you see there
        "RemoteCalendarsVSTO"?
        --Right-clicking near other toolbars...whta toolbars can you enable?
        2)I'm sorry for haven't thought of telling to shutdown Outlook :)...
        3)Damn right...however, I'd prefer people to right on the forum ;)
        4)This is quite weird. Try again, and if you still cannot subscribe, I'll write something to the SF staff.
        Bye

        lasthope83

         
    • JJ Saenz
      JJ Saenz
      2006-04-05

      DAMMIT!!! it was sooooooooooo obvious... sorry lasthope, it seems your program hadn't shown up in my Outlook because it is not only necessary to restart Outlook but also to reboot!

      I restarted my PC and there it is, wonderful program! thanks!

      But I have to immediately make a feature request... my calendar URL (from the Basecamp project management website) does not look like a calendar file (no .ics extension) so RemoteCalendar won't allow me to add it... I'm sure it's a valid calendar URL, because I use it in the Mozilla calendar...

      Apart from that, thanks a lot. The program is BRILLIANT!

       
      • Daniele Tiles
        Daniele Tiles
        2006-04-05

        Wonderful! :D...I think I definitely need to update/add a correct list on how to install RC without any problem(hopefully :))...
        About your problem...I know that some people form Basecamp uses RC...it's not important that the URL ends with .ics.
        What you need to subscribe is a resource which has got a Mime-type = "text/calendar"...this can be a dynamic page, anything!
        Try the URL suggested by Basecamp, and let me know ;)
        Bye

        lasthope83

         
    • Kurt
      Kurt
      2006-04-07

      I'm attempting to install RemoteCalendarsVSTOSetup-4.72.exe and I get the follwoing error:

      Unable to locate application file 'RemoteCalendarsVSTOSetup.msi'.

      See the setup log file located at 'C:\DOCUME~1\kvoelker\LOCALS~1\Temp\VSDD7.tmp\install.log' for more information.

      So I downloaded the VSTO 4.72 msi, tried that, and I get this error:

      "The Visual Studio Tools for Office Runtime is not installed. Please Run Setup.exe"

      I thought the 4.72 installer was supposed to install that component for me? What am I doing wrong?

      Kurt

       
      • Daniele Tiles
        Daniele Tiles
        2006-04-07

        Hi,
        for the first problem, you need to keep in the same folder both .msi and .exe files (sorry, but I didn't know too...)...hopefully, this will fix also the other...if not, check above, you'll find a link where you'll download VSTOR...
        Bye

        lasthope83

         
    • James
      James
      2006-11-20

      Hello everyone,

      I've tried installing and uninstalling the PIA, VSTOR, and RC several times (all with Outlook closed). I never get any errors installing any of them (PIA, VSTOR, and, but when I launch Outlook I do not get any dialog popup. Nor do I see any toolbar or toolbar option, and I don't see it in the "COM Add-Ons" dialog.

      I selected each of the DLL files in \program files\remotecalendars\RemoteCalendarsVSTO in the "COM Add-Ons" dialog, but each one told me it was not a valid Outlook plug-in.

      I am not running NewsGator. When I first tried to install everything, I did have .NET 1.1 and .NET 2.0 installed concurrently. I've uninstalled .NET 1.1, then I uninstalled RC, VSTO, and PIA. I then tried reinstalled PIA, VSTO, RC, and rebooting. Nothing ever complains, no error messages or anything.

      But even after all that, I can't get RC to appear in Outlook. I'm using Outlook 2003 on Windows XP Pro. The only thing that might be different for me is that I have X1 (a free desktop search engine) installed, and it includes an Outlook plugin.

      I'm open to any and all suggestions.. Thank you for your time..

      --James

       
    • James
      James
      2006-11-20

      Hello everyone,

      I forgot to mention I've tried both the MSI by itself, and then after finding this thread I've also tried using the EXE installer:

      http://prdownloads.sourceforge.net/remotecalendars/RemoteCalendarsVSTOSetup-4.72.exe?download

      It doesn't generate any errors either, but I still cannot make it appear or show up as an installable option in Outlook.

      Thanks again...

      --James

       
    • tinabops
      tinabops
      2006-11-23

      I'm having the exact same issues as James (above). Running the same environment, everything is the same. I do not have the X1 plugin, but everything else is the same. Why isn't it working?

      Thanks for your help.

       
    • I can´t get it to work either but after setting a cmd window and typing

      set VSTO_SUPPRESSDISPLAYALERTS=0

      and the started outlook, it did throw some exceptions (see next). The text is in portuguese because that´s my system language (running XP Home SP2). Hope this helps. I says something about the assembly reference (for RemoteCalendarsLibrary) not matching the manifest.

      Thanks!
      Miguel Mattos

      Não foi possível carregar arquivo ou assembly 'RemoteCalendarsLibrary, Version=1.0.2506.389, Culture=neutral, PublicKeyToken=949c2f40efb68520' ou uma de suas dependências. A definição do manifesto do assembly localizado não corresponde à referência do assembly. (Exceção de HRESULT: 0x80131040)

      ************** Exception Text **************
      System.IO.FileLoadException: Não foi possível carregar arquivo ou assembly 'RemoteCalendarsLibrary, Version=1.0.2506.389, Culture=neutral, PublicKeyToken=949c2f40efb68520' ou uma de suas dependências. A definição do manifesto do assembly localizado não corresponde à referência do assembly. (Exceção de HRESULT: 0x80131040)
      Nome do arquivo: 'RemoteCalendarsLibrary, Version=1.0.2506.389, Culture=neutral, PublicKeyToken=949c2f40efb68520'
         em RemoteCalendarsVSTO.ThisApplication.ThisApplication_Startup(Object sender, EventArgs e)
         em Microsoft.Office.Tools.Outlook.Application.OnStartup()
         em RemoteCalendarsVSTO.ThisApplication.FinishInitialization()
         em Microsoft.VisualStudio.Tools.Applications.Runtime.AppDomainManagerInternal.ExecutePhase(String methodName)
         em Microsoft.VisualStudio.Tools.Applications.Runtime.AppDomainManagerInternal.ExecuteCustomization(IHostServiceProvider serviceProvider)

      AVI: o log de ligações de assembly está desativado.
      Para ativar o log de  falhas de assembly, defina o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) como 1.
      Observação: há alguma penalidade para o desempenho associada ao log de falha de ligação de assembly.
      Para desativar esse recurso, remova o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog].

      ************** Loaded Assemblies **************
      mscorlib
          Assembly Version: 2.0.0.0
          Win32 Version: 2.0.50727.42 (RTM.050727-4200)
          CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
      ----------------------------------------
      Microsoft.VisualStudio.Tools.Applications.Runtime
          Assembly Version: 8.0.0.0
          Win32 Version: 8.0.50727.42
          CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualStudio.Tools.Applications.Runtime/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualStudio.Tools.Applications.Runtime.dll
      ----------------------------------------
      Microsoft.Office.Tools.Common
          Assembly Version: 8.0.0.0
          Win32 Version: 8.0.50727.42
          CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.Office.Tools.Common/8.0.0.0__b03f5f7f11d50a3a/Microsoft.Office.Tools.Common.dll
      ----------------------------------------
      System
          Assembly Version: 2.0.0.0
          Win32 Version: 2.0.50727.42 (RTM.050727-4200)
          CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
      ----------------------------------------
      System.Windows.Forms
          Assembly Version: 2.0.0.0
          Win32 Version: 2.0.50727.42 (RTM.050727-4200)
          CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
      ----------------------------------------
      RemoteCalendarsVSTO
          Assembly Version: 1.0.0.0
          Win32 Version: 1.0.0.0
          CodeBase: file:///C:/Arquivos%20de%20programas/RemoteCalendars/RemoteCalendarsVSTO/RemoteCalendarsVSTO.DLL
      ----------------------------------------
      Microsoft.Office.Tools.Outlook
          Assembly Version: 8.0.0.0
          Win32 Version: 8.0.50727.42
          CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.Office.Tools.Outlook/8.0.0.0__b03f5f7f11d50a3a/Microsoft.Office.Tools.Outlook.dll
      ----------------------------------------
      RemoteCalendarsLibrary
          Assembly Version: 1.0.2506.25065
          Win32 Version: 1.0.2506.25065
          CodeBase: file:///C:/Arquivos%20de%20programas/RemoteCalendars/RemoteCalendarsVSTO/RemoteCalendarsLibrary.DLL
      ----------------------------------------
      RC4IE
          Assembly Version: 1.0.0.0
          Win32 Version: 1.0.0.0
          CodeBase: file:///C:/Arquivos%20de%20programas/RemoteCalendars/RemoteCalendarsVSTO/RC4IE.DLL
      ----------------------------------------

       
  • Ted Gorton
    Ted Gorton
    2013-03-30

    I successfully installed RC (whew!!!), so it said, and the toolbar appeared; but whenever I try to add my calendar feed (Tripit) I get the error message: Remote name could not be resolved: 'webcal' .  This happens whether I paste the Tripit subscription code after http:// or replacing it.  The code is "webcal://www.tripit.com/feed/ical/private/…/tripit.ics".  what am I doing wrong?  using Outlook 2003 and Windows 7.  Thanks for any tips, I have searched the world for a plug-in that would work and thought I had found it!

     
  • Ted Gorton
    Ted Gorton
    2013-03-30

    Maybe I should have mentioned that when I go to Tools/Options/Other/Advanced/Com add-ins, I do not find RC.  But the toolbar is there!!

     
  • Ted Gorton
    Ted Gorton
    2013-03-30

    Sorry to spam you, but it suddenly started working.  I removed the word "webcal" and that, apparently, did it.  If it keeps up like this, it is a great (but REALLY hard to install) piece of software.  It still does not show up in the "Com add-ons" box but who cares?
    Thank you!!!