"No Bootable device" on MacBookPro8,1

2013-05-11
2013-08-12
  • Kirill Enykeev
    Kirill Enykeev
    2013-05-11

    So here is my problem.

    For a few days i'm trying to boot several liveusb (including Liberte, Ubuntu 12.04, FreeDOS) on my MacBookPro8,1 (early 2011), but i'm constantly getting "No Bootable device". I tried few usb sticks, few ways of "burning" them. Last time i tried by creating liveusb with rEFIt-syslinux.dmg and Seagate Momentus XT AN-SD28.ima (guide: http://www.io101.org/blog/howto/how-to-make-a-bootable-usb-flash-drive-memory-stick-for-intel-macbook-pro/) which runs OK on my Macmini5,2 (mid 2011), but i still can't boot it on my Macbook Pro. At the same time, Mountain Lion liveusb created by Disk Utility runs perfectly fine.

    Suspecting that the problem may be related to previous attempts to install refit, bootcamp or some other stuff which can mess with my EFI, i tried to clean up my primary hard drive. Hell, i even reset both PRAM and SMC and still no good.

    So, right now i'm open for suggestions. Is there are anything else i should try to fix this issue?

     
    Last edit: Kirill Enykeev 2013-05-11
  • Does the rEFInd USB flash drive or CD-R image work for you? If so, you might be able to use it and the Linux live USB drive simultaneously, using rEFInd to chainload to the Linux disk.

     
  • stephenrubio94
    stephenrubio94
    2013-08-11

    I am having the same problem on 0.7.3. I installed and reinstalled it, after shutting the computer down completely, and no luck.

     
  • Stephenru, could you please clarify:

    • What are you attempting to boot (live media, installed OSes, etc.)?
    • Is the problem with a wide variety of OSes (say, Ubuntu, Fedora, and OpenSUSE), or just some? If just some, precisely what works and what doesn't work?
    • Is rEFInd currently installed on your hard disk, or are you using a version from a USB flash drive or CD-R?
    • Can you boot the problem media by hitting the Option key (or Alt key) when the Mac chimes as you turn it on?
    • What model of Mac do you have?