Bibutils installation problem

Help
Gerben
2010-03-19
2013-05-28
  • Gerben
    Gerben
    2010-03-19

    Hello,

    I have a problem getting Bibutils to work on my refbase installation: I always get a validation error when trying to import records as bibtex or endnote xml file.

    I use bibutils 3.4 with refbase 0.9.5. Refbase is installed on a windows server so I installed the windows version in a bibutils folder in the refbase folder.

    When I run SELECT * FROM depends WHERE depends_external = "bibutils";

    i get his:

    depends_id                2
    depends_external bibutils
    depends_enabled true
    depends_path            /bibutils/

    I am aware of this forum discussion but no luck so far in solving it. I have to say that I don't know how to run a shall script (I tried through terminal on my Mac) so need some help there.

    Anyway, this is all the relevant information I can think of. I hope someone can help.

    Thanks very much and best,
    Gerben

     
  • Hi Gerben,

    I assume that you're on a server where you're allowed to run shell programs. If in doubt, please check with your ISP.

    Note that the path given in 'depends_path' in table 'depends' must be a *full* (i.e. absolute) path to the directory that contains your Bibutils programs. The path must end with a slash. On Windows, you might need to use backslashes as path separators.

    Also, please see the advice given here:

    http://www.refbase.net/index.php/Bibutils#Installing_Bibutils_for_use_with_refbase
    http://www.refbase.net/index.php/Installation-Troubleshooting#Export_of_records_results_in_a_blank_page

    E.g. please verify that the permissions of the Bibutils folder as well as of the Bibutils programs are set correctly. Also, the PHP temp/session directory must be accessible & writable by Apache/PHP/Bibutils (on a hosted server, you might need to ask your ISP for the correct temp path and enter it in variable '$sessionTempDir' in file 'initialize/ini.inc.php').

    And if PHP safe_mode is on, you'd need to specify the path to your Bibutils folder in the 'php.ini' variable 'safe_mode_exec_dir'.

    HTH, Matthias

     
  • Gerben
    Gerben
    2010-03-19

    Hi Matthias,

    Thank you very much for your quick response.

    Note that the path given in 'depends_path' in table 'depends' must be a *full* (i.e. absolute) path to the directory that contains your Bibutils programs. The path must end with a slash. On Windows, you might need to use backslashes as path separators.

    I have set the full path like this: http://yiddish-sources.com/bibliography/bibutils/
    I assume this is what is meant? When checking with   SELECT * FROM depends;  this is the given path so I assume it is ok.

    E.g. please verify that the permissions of the Bibutils folder as well as of the Bibutils programs are set correctly. Also, the PHP temp/session directory must be accessible & writable by Apache/PHP/Bibutils (on a hosted server, you might need to ask your ISP for the correct temp path and enter it in variable '$sessionTempDir' in file 'initialize/ini.inc.php').

    I can't seem to set permissions myself so asked my hosting compnay to do it. Same for the PHP temp/session directory. I will post again once this is done.

    Safe mode is off by the way.

    Thanks again,
    Gerben

     
  • I have set the full path like this: http://yiddish-sources.com/bibliography/bibutils/
    I assume this is what is meant?

    No.  You need a file system path, as if you were running the programs from the command line.  You do NOT want an http:// URI.

     
  • Gerben
    Gerben
    2010-03-19

    Ok, thanks. Since the bibutils folder resides inside the refbase folder (which is called bibliography) in the root I assume that makes the file system path:

    /bibliography/bibutils/

     
  • Since the bibutils folder resides inside the refbase folder (which is called bibliography) in the root I assume that makes the file system path:

    /bibliography/bibutils/

    If your refbase folder is really located at the root of your server (NOT your hosted account), then yes. If the refbase folder is instead located at the "root" of your hosted account, then you'd need to prefix the given path ('/bibliography/bibutils/') with the full path to your account. If in doubt, please ask your hosting company for the correct path.

    Matthias

     
  • Gerben
    Gerben
    2010-03-23

    Just to provide an update:

    1) according to the hosting company /bibliography/bibutils is correct
    2) setting permissions of the Bibutils folder as well as of the Bibutils programs works differently according to them because it's a Windows IIS server (no CHMOD); they have set it for me and it is 777 in both cases (if I check via FTP)
    3) according to the hosting company the $sessionTempDir =session_save_path() variable as specified in ini.inc.php should work with the default specified path

    It doesn't work still, could the trouble be because of the Windows server?

    Best,
    Gerben

     
  • Are you using the bibutils binaries made for Windows?  Are you able to check the error log?  Bibutils will work on Windows+Apache & I think that it has been reported to work on Windows+IIS.

    -Rick

     
  • Gerben
    Gerben
    2010-03-23

    Thanks for your reply.

    Are you using the bibutils binaries made for Windows?{/quote]

    Yes.

    Are you able to check the error log?

    Just checked but only managed to see what looks like the general log via the Plesk control panel of my hosting company. I will ask them how to access the error logs.

    Bibutils will work on Windows+Apache & I think that it has been reported to work on Windows+IIS.

    That is good to hear. Sorry for all the questions, building a website with Drupal and Refbase is one thing, troubleshooting this kind of thing another, but I am learning :)

    Gerben

     
  • Gerben
    Gerben
    2010-03-24

    Ok, the hosting company has also set the full path to bibutils but that did not make a difference.

    I have had a look at the log after I tried to export some search results and this is the message:

    2010-03-24 11:14:26 W3SVC18927 WEB01 10.0.0.103 GET /bibliography/search.php sqlQuery=SELECT%20author%2C%20title%2C%20type%2C%20year%2C%20publication%2C%20abbrev_journal%2C%20volume%2C%20issue%2C%20pages%2C%20keywords%2C%20abstract%2C%20thesis%2C%20editor%2C%20publisher%2C%20place%2C%20abbrev_series_title%2C%20series_title%2C%20series_editor%2C%20series_volume%2C%20series_issue%2C%20edition%2C%20language%2C%20author_count%2C%20online_publication%2C%20online_citation%2C%20doi%2C%20serial%20FROM%20refs%20WHERE%20serial%20RLIKE%20%22.%2B%22%20ORDER%20BY%20created_date%20DESC%2C%20created_time%20DESC%2C%20modified_date%20DESC%2C%20modified_time%20DESC%2C%20serial%20DESC&client=inc-refbase-1.0&formType=sqlSearch&submit=Cite&viewType=&showQuery=0&showLinks=1&showRows=5&rowOffset=&wrapResults=0&citeOrder=creation-date&citeStyle=APA&exportFormat=RIS&exportType=html&exportStylesheet=&citeType=html&headerMsg= 80 - 10.0.0.103 HTTP/1.0 - - - yiddish-sources.com 200 0 0 22477 905 1248

    (The website I am talking about is: http://yiddish-sources.com and the bibliography at http://yiddish-sources.com/bibliography)

    Gerben

     
  • That is an access log entry, but is not a PHP error.  You may have another log that records errors and/or you may need to configure your server to record them somewhere.

     
  • Gerben
    Gerben
    2010-03-25

    I just got the message from the hosting company that they don't record php logs and that errors are only displayed in the browser. They cant switch it on for individual websites so no error logs to examine unfortunately.

     
  • This is difficult to troubleshoot without seeing error messages.  I do not think the primary developers have easy access to IIS, but you may look for a similar setup to your hosting company that you can test on & enable error logging there.

     
  • Gerben
    Gerben
    2010-03-26

    Ok, thanks, this is unfortunate indeed. I will see what I can find.