loupe -> error on a different server

Help
2012-04-13
2013-05-28
  • Knut Krüger
    Knut Krüger
    2012-04-13

    Hi to all

    http://81.88.24.149/equine/web/refdb/  the loupe funktion is working on a temporary server
    http://references.equine-behaviour.de/  shows: Error 1065 : Query was empty
    The edit function  is working
    the code was packed with tar wget to the new server and extracted with wget

    The database is the same, any suggestions?

     
  • The "show details" links work for me on both servers.  Did you fix it or can you explain how to replicate the issue?

     
  • Knut Krüger
    Knut Krüger
    2012-04-13

    I just tired it again

    It is working when not logged in and it is working for the first detail page after login.
    The second detail page will cause the error.
    After logout/login the problem starts at the beginning.
    one visible the second not.

     
  • So what else is different between the two servers?  Were file permissions preserved when you tar-ed things up?  Same LAMP stack with the same settings for apache and php?  By "the database is the same" do you mean that there is only a single database for the two servers or that you attempted to copy the database (and, if the latter, how did you do it)?

     
  • Knut Krüger
    Knut Krüger
    2012-04-13

    File permissions are identically. The operating system is different working system is lenny not working is sqeeze
    its physically the same database ( the init files are the same) , because the not working system is a temporarily unit the right one is working

     
  • Knut Krüger
    Knut Krüger
    2012-04-13

    Maybe PHP settings?

     
  • Knut Krüger
    Knut Krüger
    2012-04-13

    suhosin?

    suhosin: ALERT - configured GET variable value length limit exceeded - dropped variable 'sqlQuery' (attacker '66.249.72.77', file '/var/www/web11//web/uni/refdb/search.php')

     
  • Knut Krüger
    Knut Krüger
    2012-04-13

    yep suhosin.get.max_value_length increased - its working