Can't Add Records Over the Internet

Help
Richard
2014-07-10
2014-07-10
  • Richard
    Richard
    2014-07-10

    Hi there.

    I have a refbase site set up and adding records on the webserver (i.e. accessing through localhost/refbase) works perfectly but when I try to do the same thing over the internet filling out the information and clicking the "save record" button causes the next page to be blank with just the phrase "The specified URL cannot be found". I use the same user account trying to add the record while keeping all the information the same. I've enabled/configured everything on php.ini that was mentioned in the installation instructions. The webserver is running Windows 2008 R2 and XAMPP 3.2.1. Has anyone experienced an issue like this before?

     
    • I do not remember seeing a report like this before. Things to check:
      * Another client computer and another web browser
      * Check to see there are no localhost-specific directives in initialize/ini.inc.php and your httpd.conf configuration
      * Enable full logging and check your logs for what URL can't be accessed (and, hopefully, why)

       
  • Richard
    Richard
    2014-07-10

    On another note, is there any way around accessing user logins when all the passwords have been lost? I'm dealing with an installation right now that was done before I got here and I have yet to find a way to change a user password in the database so I can log in and make more users.

     
    • This issue was just raised on the refbase-talk mailing list. I suggest you join that & search through that archive if you have future support questions.

      Here's the solution (from Antonio):
      a) Open the file initialize/ini.inc.php in a text editor and change the value of $addNewUsers to 'everyone'.
      b) Then load the user_details.php and create a new user in the refbase web interface.
      c) Go back to the initialize/ini.inc.php file and change the $adminLoginEmail value to the user email you created in the previous step.
      d) Then goto the 'manage users' page in your browser (users.php) and click the 'edit details' link for the account password you wish to reset to change the password (the one I forgot the password of in my case)
      e) Re-edit initialize/ini.inc.php to return the $adminLoginEmail and $addNewUsers variables.
      f) Delete the new user you created (if you don't need it).