does it work with PHP5 ?

Help
Jan Lorenz
2010-06-03
2013-05-28
  • Jan Lorenz
    Jan Lorenz
    2010-06-03

    I switched the default interpretation of .php files to PHP5 on my server.
    No refbase gives the error.

    Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /homepages/38/d27074435/htdocs/refbase/includes/include.inc.php  on line 5213
    Warning: fopen(http://janlo.de/refbase/show.php?records=all&submit=Cite&showRows=5&citeOrder=creation-date&client=inc-refbase-1.0&wrapResults=0) [function.fopen]: failed to open stream: no suitable wrapper could be found in /homepages/38/d27074435/htdocs/refbase/includes/include.inc.php on line 5213
    

    show.php seems not to work properly anymore.

     
  • Yes, refbase works with PHP5 & there are many who use it on PHP5 (including myself).  While there are development efforts to minimize the use of fopen in future versions, you can set:

       allow_url_include = On
       allow_url_fopen = On

    on your server to avoid seeing that warning message.

     
  • Jan Lorenz
    Jan Lorenz
    2010-06-07

    Hi,

    the solution indeed removes the problem on the initial page of refbase. But there is still a more serious one, which remained.
    I used show.php to show a list of publications on my homepage. This is done by

    require('http://janlo.de/refbase/show.php?author=lorenz&client=inc-refbase-1.0&without=dups&wrapResults=0&submit=Cite&citeStyle=APA+bold&citeOrder=year&showRows=30&showLinks=1');
    

    This still gives the following error message on my homepage:

    Warning: require() [function.require]: URL file-access is disabled in the server configuration in /homepages/38/d27074435/htdocs/blog/wp-content/themes/k2-custom/page.php  on line 28
    Warning: require(http://janlo.de/refbase/show.php?author=lorenz&client=inc-refbase-1.0&without=dups&wrapResults=0&submit=Cite&citeStyle=APA+bold&citeOrder=year&showRows=30&showLinks=1) [function.require]: failed to open stream: no suitable wrapper could be found in /homepages/38/d27074435/htdocs/blog/wp-content/themes/k2-custom/page.php on line 28
    

    Any solution?

    Best regards,

    Jan Lorenz

     
  • Perhaps you applied those settings only to your refbase directory & not to your site (as it is 'blog/wp-content/themes/k2-custom/page.php' that is producing the message).  I can't think of anything outside of those settings that could trigger this warning & this is no longer a refbase warning (but is a problem with page.php).

    If you are unable to fix your server settings or page.php, you can look at an alternative means to embed the data:
    http://www.refbase.net/index.php/Integrating_refbase_into_your_web_site

    -Rick

     
  • Jan Lorenz
    Jan Lorenz
    2010-06-07

    Thanks Rick!
    I tried out putting a php.ini  in blog/wp-content/themes/k2-custom/page.php already without success. But it worked when I also put the same php.ini in the main wordpress directory (and in the main refbase directory).

    Best
    Jan