Error 403 - even as admin

Help
Wolfgang
2009-01-25
2013-05-28
  • Wolfgang
    Wolfgang
    2009-01-25

    Dear refbase experts,

    Thanks for your great work, your library-system is really totally helpful.

    my problem: I updated from the last version to the current version, everything works fine,
    but after uploading a pdf-file (via add new entry),  i always get the error 403 access denied if
    I want to  read this file from any list ..

    All files I uploaded before the update are ok, I dont get this error when klicking the pdf-link

    I dont know why,  with the version before everything worked fine.
    I saw in the directory on the server that refbase creates folders with authorname
    and year now, maybe it has something to do with that?

    wo can help me?

    what can I do - need to be able to read the uploaded pdf-files ...

    Wolfgang

     
    • Hi Wolfgang,

      thanks for the heads-up,  I appreciate it!

      > my problem: I updated from the last version to the current version,
      > everything works fine, but after uploading a pdf-file (via add new
      > entry),  i always get the error 403 access denied if I want to  read
      > this file from any list ..

      What is the structure of the PDF links generated by refbase-0.9.5? Could you give an example? And, for comparison, what is the old structure for PDF links generated by refbase-0.8.0?

      > I dont know why,  with the version before everything worked fine. I
      > saw in the directory on the server that refbase creates folders with
      > authorname and year now, maybe it has something to do with that?

      So, with your refbase previous version, refbase was not creating sub-folders -- and now it does? Maybe it's just that the permissions of the newly created folders are set incorrectly?

      Have you tried adjusting the permissions of these newly created folders for one of the links that give you an error? Can you then access that link from your browser??

      When refbase creates sub-directories, folder permissions are set in function 'recursiveMkdir()' (in file 'modify.php', right at the bottom of the file). In that function, you may want to try to comment out this line:

      mkdir($path, 0770); // create directory

      I.e. prefix it with two slashes so that it reads:

      // mkdir($path, 0770); // create directory

      Then, remove all slashes at the beginning of the next three code lines, i.e. make them look like this:

      $oldumask = umask(0);
      mkdir($path, 0755); // create directory
      umask($oldumask);

      Save the file and try again? Does it work now?

      Alternatively, you can disable the automatic filing into sub-folders by setting variable '$moveFilesIntoSubDirectories' in file 'initialize/ini.inc.php' to "never":

      $moveFilesIntoSubDirectories = "never";

      Hope this helps. Let us know if you still can't get it working.

      Matthias

       
    • Wolfgang
      Wolfgang
      2009-01-26

      Thanks a lot Matthias,

      i needed the help of our admin, he configured the modify.php like you proposed .  Now everything works fine.
      Thanks a lot !

      Robert our admin asks, wether you plan also a version of refbase which runs on freeBSD ? In this case  the system might become interesing for the whole working group here at the department of physiks

      anyway I will promote your system to the scientific community, because I really love it.

      Wolfgang

       
      • refbase works on FreeBSD as-is & is what I use for my primary server.

        --Rick

         
    • Hi Wolfgang,

      > Now everything works fine

      I'm glad that this solved your problem!

      > Robert our admin asks, wether you plan also a version of
      > refbase which runs on freeBSD ?

      I'd love to! But I'm not familiar with freeBSD, and I don't know what would be required to make it run under freeBSD. refbase just uses a regular PHP+MySQL+Apache setup, so I don't think it should be hard to get it running under any unixy system. Maybe others in this forum can contribute further advice for freeBSD...

      > anyway I will promote your system to the scientific
      > community, because I really love it.

      Thanks, spreading the word is always welcome!

      Regards, Matthias