Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Uploads

Help
2007-10-12
2013-05-28
  • I begin to enjoy Refbase !

    But I have some difficulties to understand the files uploading. In my ini.inc.php I have given $filesBaseDir = "/home/refbase/"; and $filesBaseURL = "". this directory have the rights 755 www:www. Refbase is installed in /usr/local/www/data on FreeBSD 5.5.

    Records of data are OK but when I want to upload a pdf file I obtain a blank page with http://164.81.23.23/refbase/modify.php?proc=1 in the adress bar of my browser. And the file is not uploaded ! Connected as Admin, I presume I have sufficient rights to upload, no ?

    What is the problem ?

    Thanks for the help

     
    • Hi,

      The variable '$filesBaseDir' must contain the full server path to the base directory that shall contain any uploaded PDF files.
      The variable '$filesBaseURL' must contain the corresponding URL path to the files directory given in '$filesBaseDir'.

      As an example, if you'd like to store uploaded files within a directory named "files" inside your refbase root (= scripts) directory, then you could use:

      $filesBaseDir = '/usr/local/www/data/refbase/files/';
      $filesBaseURL = 'files/';

      The above example assumes that your refbase root directory is located at '/usr/local/www/data/refbase/'. Note that variable '$filesBaseURL' contains a relative URL path (relative to your refbase root directory).

      If, however, your files directory is outside of your refbase root directory, say, on the uppermost level of your server's DocumentRoot, you'd need to specify an absolute URL path for variable '$filesBaseURL':

      $filesBaseDir = '/usr/local/www/data/files/';
      $filesBaseURL = '/files/';

      This assumes that your server's DocumentRoot is at '/usr/local/www/data/'.

      In addition, please see the comments above these variables in file 'ini.inc.php'.

      As you noted, you'll also have to make sure that the permissions of your files directory are set correctly.

      It might be also worth to check your server's error log, and to enable PHP error reporting. To enable error reporting, please set the following variables in your server's active 'php.ini' file:

      error_reporting  =  E_ALL
      display_errors = On

      Btw, for any future posts, it would be nice if you could post your name (or log into the SourceForge site first) so it's easier for us to associate your posts/issues with a certain user. This avoids confusion. Thanks!

      Matthias

       
    • micercle
      micercle
      2007-10-13

      Hello

      In my ini.inc.php I have set

      $filesBaseDir = '/usr/local/www/data/refbase/files/';
      $filesBaseURL = 'files/';

      The directory files have the rights 755, and owned by the apache user

      My documentRoot is at /usr/local/www/data/

      I try to insert a new record. Without files, all is ok. When I want to upload the corresponding file, with   the name vahrun.pdf I have the message

      Fatal error: Call to undefined function iconv() in /usr/local/www/data-dist/refbase/includes/include.inc.php on line 3838

      Micercle

       
    • micercle
      micercle
      2007-10-15

      Well, with iconv support refbase works according to what is writen in the documentation  :) !! Refbase works very well.

      I will try to read more carefully the different sources of information in the future !!

      Thanks for yours hints and answers

      Micercle

       
    • Well, with iconv support refbase works according to what is writen in the documentation  :) !! Refbase works very well.

      I will try to read more carefully the different sources of information in the future !!

      Thanks for yours hints and answers

      Micercle