CSL version

Help
Sathej
2010-09-08
2012-11-20
  • Sathej
    Sathej
    2010-09-08

    How do we get DAISY to run on the opensource CSL version of REDUCE? The LOAD DAISY command always seems to return an error. Appreciate any help.

    Thanks,
    Sathej

     
  • Arthur Norman
    Arthur Norman
    2010-09-08

    The last time I checked the Daisy authors only made their code available in binary form, and only in a version that would work with some of the PSL releases of Reduce. So the easiest way would be to persuade the people who wrote and own rights to DAISY to release a version that works with the CSL version of Reduce. If they were willing to release the source under the license that Reduce uses I would be delighted to add it as a standard package available automatically to anybody. If they are only prepared to release a binary then if they contacted me on acn1@cam.ac.uk I can assist in trying to make it easy for them to create a CSL-compatible one.  Naturally what they do with their code is 100% their choice! But as an actual or potential user of daisy you may like to ask them…  Ah yes, if they were happy to release source but under some license that clashed with the one Reduce uses, etc etc etc we can try to help with that too.

    Arthur