Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Cannot Compile/Install

Help
2007-03-06
2013-06-03
  • slothjammin
    slothjammin
    2007-03-06

    I'm having problems installing. I've tried the two most recent versions with the same errors.  I believe I have all the dependencies.
    openSUSE 10.1
    uname -a:
    2.6.16.27-0.6-smp #1 SMP Wed Dec 13 09:34:50 UTC 2006 i686 i686 i386 GNU/Linux

    Below is the output of ./configure and make. 

    sudo ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking for dirent.h that defines DIR... yes
    checking for library containing opendir... none required
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
    checking whether -R must be followed by a space... neither works
    checking for gethostbyname... yes
    checking for connect... yes
    checking for remove... yes
    checking for shmat... yes
    checking for IceConnectionNumber in -lICE... yes
    X libraries are found in /usr/X11R6/lib
    X includes are found in /usr/X11R6/include
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking alsa/asoundlib.h usability... yes
    checking alsa/asoundlib.h presence... yes
    checking for alsa/asoundlib.h... yes
    checking endian.h usability... yes
    checking endian.h presence... yes
    checking for endian.h... yes
    checking sys/soundcard.h usability... yes
    checking sys/soundcard.h presence... yes
    checking for sys/soundcard.h... yes
    checking dlfcn.h usability... yes
    checking dlfcn.h presence... yes
    checking for dlfcn.h... yes
    checking jack/jack.h usability... yes
    checking jack/jack.h presence... yes
    checking for jack/jack.h... yes
    checking sys/time.h usability... yes
    checking sys/time.h presence... yes
    checking for sys/time.h... yes
    checking for unistd.h... (cached) yes
    checking vorbis/vorbisfile.h usability... yes
    checking vorbis/vorbisfile.h presence... yes
    checking for vorbis/vorbisfile.h... yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking for u_int16_t... yes
    checking for u_int32_t... yes
    checking for u_int64_t... yes
    checking for isnan in -lm... yes
    checking for deflate in -lz... no
    checking for IceOpenConnection in -lICE... yes
    checking for SmcOpenConnection in -lSM... yes
    checking for XOpenDisplay in -lX11... yes
    checking for XShmQueryVersion in -lXext... yes
    checking for XFixesQueryExtension in -lXfixes... yes
    checking for XDamageQueryExtension in -lXdamage... yes
    checking for vorbis_info_clear in -lvorbis... yes
    checking for ov_open in -lvorbisfile... yes
    checking for vorbis_encode_init in -lvorbisenc... yes
    checking for ogg_stream_init in -logg... yes
    checking for theora_encode_YUVin in -ltheora... yes
    checking for pthread_mutex_lock in -lpthread... yes
    checking for snd_pcm_drain in -lasound... yes
    checking for dlopen in -ldl... yes
    checking whether closedir returns void... no
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible malloc... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating src/Makefile
    config.status: creating include/Makefile
    config.status: creating doc/Makefile
    config.status: creating config.h
    config.status: config.h is unchanged
    config.status: executing depfiles commands

    ****************************************

    Audio driver that will be used: ALSA

    Compile with Jack support: Enabled

    ****************************************

    sudo make
    make  all-recursive
    make[1]: Entering directory `/home/bfrancom/rmd/recordmydesktop-0.3.3'
    Making all in src
    make[2]: Entering directory `/home/bfrancom/rmd/recordmydesktop-0.3.3/src'
    if gcc -DHAVE_CONFIG_H -I. -I. -I..  -I../include   -D_THREAD_SAFE -pthread -Wall -I/usr/X11R6/include  -g -O2 -MT recordmydesktop-recordmydesktop.o -MD -MP -MF ".deps/recordmydesktop-recordmydesktop.Tpo" \   -c -o recordmydesktop-recordmydesktop.o `test -f 'recordmydesktop.c' || echo './'`recordmydesktop.c; \ then mv -f ".deps/recordmydesktop-recordmydesktop.Tpo" ".deps/recordmydesktop-recordmydesktop.Po"; \ else rm -f ".deps/recordmydesktop-recordmydesktop.Tpo"; exit 1; \ fi
    In file included from ../include/recordmydesktop.h:35,
                     from recordmydesktop.c:28:
    ../include/rmdtypes.h:56:18: error: zlib.h: No such file or directory
    In file included from ../include/recordmydesktop.h:35,
                     from recordmydesktop.c:28:
    ../include/rmdtypes.h:228: error: expected specifier-qualifier-list before 'gzFile'
    In file included from ../include/recordmydesktop.h:37,
                     from recordmydesktop.c:28:
    ../include/rmdfunc.h:465: error: expected declaration specifiers or '...' before 'gzFile'
    ../include/rmdfunc.h:481: error: expected declaration specifiers or '...' before 'gzFile'
    make[2]: *** [recordmydesktop-recordmydesktop.o] Error 1
    make[2]: Leaving directory `/home/bfrancom/rmd/recordmydesktop-0.3.3/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/bfrancom/rmd/recordmydesktop-0.3.3'
    make: *** [all] Error 2

     
    • Notice this:
      checking for deflate in -lz... no

      You miss the development package for zlib.
      In Debian it is named zlib1g-dev.

      This is a bug, since the configure script should
      exit after not finding the dependency (it's fixed
      on the CVS and will not exist in the next version).

      What you need to do now, is install the appropriate headers for zlib
      and then rerun the configure script. After that, make should proceed
      normally.

      John

       
      • slothjammin
        slothjammin
        2007-03-08

        That fixed that part.  Thanks!!
        Now I just need to install the pyGTK headers so the gtk portion will install.  I cannot find them in Yast.  I'll ask on a openSUSE forum.

         
    • I'm glad it worked.

      As for pyGTK, notice that the package is commonly named python-gtk.
      At least on debian, it's name is python-gtk2-dev. RPM distributions
      usually use the postfix devel for headers, so it will probably
      be named python-gtk2-devel.
      Of course that's guessing and a distribution specific forum will provide you with better answers.

      John