Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Very, very, low volume on recording.

2008-03-02
2013-06-03
  • Hi,
    problem is that audio gets recorded, but with barely audible volume. One has to really concentrate to hear something at full volume, but the audio is there. Every slider is maxed in alsamixer. I am using Gentoo, kernel 2.6.24 and 0.3.7.1 build of recordMyDesktop from Gentoo repository. Sound system is alsa.

    Any ideas how to get normal volume?

    Br,
    Peter

     
    • Oh, forgot to mention that I am NOT using microphone, but I want to record everything straight from the sound system. Card is integrated Intel HDA and chip is Realtek ALC885.

       
    • Assuming that your wave and PCM channels are
      maxed for both playback and capture, I don't
      really know why you would get low volume.

      Are you sure that you have selected the right source
      for recording (usually named "Wave"  or "Mix")?

      You can review your capture settings by running:
      ~$ alsamixer -V capture
      (use space to toggle sources)

      If you are certain that your mixer settings are
      properly set for recording, you can use
      the following method to go around the problem:

      First install audacity and oggz-tools (in some
      distributions they are packaged with liboggz).

      Then, assuming that your file is named out.ogv,
      do the following:

      ~$ oggzrip -c vorbis -o out-audio.oga out.ogv
      ~$ oggzrip -c theora o out-video.ogv out.ogv

      Then, open out-audio.oga with audacity, and perform
      any relevant effects that you might want (amplify,
      remove noise, normalize , etc.). Make sure though
      to use only effects that do not change the duration
      of the recording.

      Then, save the changes you've made and run:

      ~$ oggzmerge -o out_amplified.ogv out-audio.oga out-video.ogv

      Now out_amplified.ogv will have cleaner and louder audio,
      without any hassle on synchronizing the two streams.

       
    • Great answer and a fast one, thanks alot!

      I'll play more with the recording source, but yes my Wave and Mix are maxed.
      Very nice of you to provide also a workaround, I'm getting better service here than with commercial software ;)