#43 ubuntu 9.10 Jack support problem

open
5
2009-11-09
2009-11-09
psc
No

i have compiled the last version of recordmydesktop (3.8.1) with --enable-jack

when starting the record i have this message:
recordMyDesktop is not compiled with Jack support!

./configure --enable-jack:

checking for jack_activate in -ljack... yes
checking for snd_pcm_drain in -lasound... yes
****************************************

Audio driver that will be used: ALSA

Compile with Jack support: Enabled

****************************************

same problem for the package in ubuntu 9.10: 3.8.1
pat

Discussion

  • psc
    psc
    2009-11-12

    here's the output of ldd:
    ldd ./recordmydesktop
    linux-gate.so.1 => (0x00b6a000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0x00229000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0x00ac4000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0x0063a000)
    libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x0074e000)
    libtheora.so.0 => /usr/lib/libtheora.so.0 (0x00d15000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0x007ba000)
    libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00ef7000)
    libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0x00bbf000)
    libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x009d4000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00110000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00557000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x00a09000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00d80000)
    libz.so.1 => /lib/libz.so.1 (0x005d6000)
    libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x00a6f000)
    libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00232000)
    libuuid.so.1 => /lib/libuuid.so.1 (0x00113000)
    libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00b1a000)
    librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0x001f2000)
    /lib/ld-linux.so.2 (0x0048c000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x00ee0000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00b22000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00a2d000)

    no libjack there! maybe it's a problem of linking the link?

     
  • psc
    psc
    2009-11-12

    version 0.3.8 is working perfectly.

     
  • jkroll
    jkroll
    2010-04-08

    I have the same problem. Please do apply this patch!