"Unclosed token" error

help-mt
mikelbyl
2006-06-15
2013-04-09
  • mikelbyl
    mikelbyl
    2006-06-15

    Hi, I tried to install the MT plugin and everything went fine until I tried to import entries from my source feed. I got the following error:

    unclosed token at line 21, column 1, byte 736:
            <pubDate>Wed, 14 Jun 2006 16:49:26 -0400</pubDate>
        <author></author>
        <source url="" link="
    ^
    at /usr/local/lib/perl5/site_perl/5.6.0/sun4-solaris/XML/Parser.pm line 185

    I actually deleted that post in the source feed and tried again but got a similar error message.

    I can provide more details if needed, but for a first pass I thought I'd just post this to see if anyone has seen this problem before and has a fix.

     
    • Michael Frumin
      Michael Frumin
      2006-06-15

      what's the URL of the source feed?

       
    • mikelbyl
      mikelbyl
      2006-06-15

      It's here:

      "http://www.trigence.com/refeed/out/rss.php?user=1"

       
      • mikelbyl
        mikelbyl
        2006-06-15

      • Michael Frumin
        Michael Frumin
        2006-06-15

        wow, that is f-ed.  can you look in your apache error log to see if it's reporting any problem?

         
    • mikelbyl
      mikelbyl
      2006-06-15

      I'm trying to get that info from my webhost.

      What did you do to "see" the problem?

       
      • Michael Frumin
        Michael Frumin
        2006-06-15

        well, the XML feed simply ends mid-tag.  clearly it's bailing out somewhere.

         
    • mikelbyl
      mikelbyl
      2006-06-15

      Is there any chance it's simply a conflict between the reported and served charsets? In other environments (MT for one) I've had extremely annoying issues due to servers that reported serving different charsets than the files identified themselves as.

       
    • ylejeune
      ylejeune
      2006-12-29

      Same thing here !
      Seem to me that the source should be closed ...
      Can you tell me where it's defined so that I can correct it ?

      "Going to import entries from http://blogs.ionis-group.com/refeed/out/rss.php?user=1

      Content-Type: text/html Got an error:

      no element found at line 21, column 104, byte 1003:
              <pubDate>Fri, 29 Dec 2006 17:03:31 +0100</pubDate>
          <author>Eric CHREIKI</author>
          <source url="http://feeds.feedburner.com/Excellencia" link="http://blogs.ionis-group.com/excellencia/">
      =======================================================================================================^
      at /usr/lib/perl5/vendor_perl/5.8.8/i686-linux/XML/Parser.pm line 187"