Hello List,
I got a problem with rdesktop:
rdesktop -u $USER -p USER -s notepad $IP
still starts the normal Windows desktop. "notepad" is just an expamle, other Programs won't work as well.

I also tried following variations:
rdesktop -u $USER -p $PASSWORD -s "notepad" $IP
rdesktop -u $USER -p $PASSWORD -s 'notepad' $IP
rdesktop -u $USER -p $PASSWORD -s "notepad.exe" $IP
rdesktop -u $USER -p $PASSWORD -s 'notepad.exe' $IP
rdesktop -u $USER -p $PASSWORD -s notepad.exe $IP

There is no output in the shell that I start rdesktop with. As far as I know there is no possibility to achieve a higher Log Level - is this correct?

I tried two Clients both with Ubuntu 12.04.3 LTS.
I used rdesktop 1.7.0, 1.7.1 and 1.8.1 - they all just start the Windows desktop, notepad is not even started.
As a RDP Server I tried Windows XP SP3 and Windows Server 2003, both just showing the Windows Desktop.

Using SeamlessRDP (http://www.cendio.com/seamlessrdp/) did not help:
rdesktop -u $USER -p $PASSWORD -A -s 'c:\Programme\ThinLinc\
WTSTools\seamlessrdpshell.exe notepad' $IP
lead to the same situation.

I found someone who seemed to have the same problem:
> I tried your seamess setup instructions. They work when the server is Windows 2003 but not when it is XP SP2. I have fast user switching turned on on the XP box. It shows the full screen instead of the singe app (say notepad).
He solved it with ensuring that no user was currently logged on:
>After some trial and error I was able to start an app on XP box by ensuring that no user is currently logged onto the XP box.
This does not work for me.

I also found: https://help.ubuntu.com/community/SeamlessVirtualization
> Enable Terminal Services: in the control panel, click User Accounts. Ensure that Use the Welcome Screen and Fast User Switching are both checked. Click OK. Note: Fast User Switching is not available to computers that are part of a network domain.
This does not solve my Problem either :(.

To me it seems, that the "-s" is lost somewhere between the Client and the Server. In the Windows Log I can not find any errors, there is just the information that someone logged on via RDP. In the Windows Logs there is no hint, that the user wanted to start notepad.

Does someone have some pointers for me where to look for the cause of this problem? Did anyone have the same Problem and got so solve it? I'd appreciate every help :)


Jonas N.