Hi Roland,

I guess you already have but i got to ask, did you initialize a kerberos ticket for the AD realm ?

Could you build rdesktop with --with-debug-credssp and provide the logs ?


Regards,

Henrik Andersson


On 08/19/2013 01:56 AM, Roland Soderstrom wrote:
Hi,

I managed to compile ok but it fails with the Authentication.
I tried linking the gss,krb5 libs in there but didn't work.

This is how I managed to compile
# cd libgssglue-0.4
# vi src/Makefile
CFLAGS = -O2 -DUSE_SOLARIS_SHARED_LIBRARIES
# export LIBS="-lkrb5 -lkrb5support -lgssapi_krb5"
# ./configure
# /usr/local/bin/make
# /usr/local/bin/make install

# cd ../rdesktop-1.8.0
# ./configure -disable-smartcard
# /usr/local/bin/make

I also tried to copy around the /etc/gss/mech file to /etc/mech.conf and /usr/local/etc/gss/mech

# ./rdesktop windows2012server
ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?
Failed to connect, CredSSP required by server.

If I do the exact same thing on Linux Mint 15 connecting to the same winserver I get the same error
On the same Linux Mint 15 host I happily connect to the same win2012server with Remmina.
But Remmina is not there for Solaris 10...

This must be a problem with Authentication and rdesktop.


-      Roland




------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite!
It's a free troubleshooting tool designed for production.
Get down to code-level detail for bottlenecks, with <2% overhead. 
Download for free and get started troubleshooting in minutes. 
http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk


_______________________________________________
rdesktop-users mailing list
rdesktop-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rdesktop-users


-- 
---
Henrik Andersson
Cendio AB        http://cendio.com
Teknikringen 8        http://twitter.com/ThinLinc
583 30 Linköping    http://facebook.com/ThinLinc
Phone: +46-13-214600    http://plus.google.com/112509906846170010689