Hi list !
 
I have compiled the latest rdesktop on a IBM rs6000 PowerPC machine running AIX 5.3 but I experience some problems.
 
First of all I run configure which told me I had to add a couple of dependencies (cproto and openssl) but then resolved those, "compile" run smoothly.
 
Then "make" ended up with an error:
 
        cproto -DMAKE_PROTO  bitmap.c cache.c channels.c cliprdr.c disk.c mppc.c ewmhints.c      iso.c licence.c mcs.c orders.c parallel.c printer.c printercache.c  pstcache.c rdesktop.c rdp5.c rdp.c rdpdr.c rdpsnd.c rdpsnd_oss.c  secure.c serial.c tcp.c xclip.c xkeymap.c xwin.c lspci.c seamless.c >> proto.h
rdpsnd_oss.c:36:27: error: sys/soundcard.h: No such file or directory
        cat proto.tail >> proto.h
        rm -f *.o *~ vnc/*.o vnc/*~ rdesktop rdp2vnc
        rm -rf autom4te.cache config.log config.status Makefile
        ./config.status
./config.status: not found
 
make: 1254-004 The error code from the last command is 1.
Trying again but just issuing "make install", it worked and produced a good executable.
Unfortunately running the newly generated rdesktop executable, I get the following error:
 
rdesktop -g1024x768 -a16 192.168.1.241
WARNING: rdp_out_unistr: iconv_open[ISO8859-1 -> UTF-16LE] fail -1
ERROR: xmalloc 0
 
and the program closes suddenly while working with MSoffice.
Also, but much less important, I have a Italian keyboard and there is no way to have the keymap working with special caracters.
 
Does anyone have some ideas on what I could possibly alter in order to make it work as it should ?
Would it help posting any of the logs ?
 
Cheers
 
Valter