JVM Creation Failed

Help
Anonymous
2012-10-17
2014-12-03

  • Anonymous
    2012-10-17

    Hello,

    When I start rapsor.exe, i get the error message 'JVM Creation Failed'.

    I have the following:
    Java runtime V7 update 9
    Java 3D 1.5.1
    XP sp3

    I hope you know what is causing this error?

    Best regards,

     
  • Yves OESCH
    Yves OESCH
    2012-12-18

    Same problem for me.
    I've just downloaded installed Java, the 3D libraries and  Rapsor.zip and started the file
    …\rapsor\rapsor\bin\rapsor.exe

    My configuration:
    Win7

    Output of the command java -version:
    c:\Program Files (x86)\Java\jre7\bin>java -version
    java version "1.7.0_10"
    Java(TM) SE Runtime Environment (build 1.7.0_10-b18)
    Java HotSpot(TM) Client VM (build 23.6-b04, mixed mode, sharing)

    Any solution?

     
  • ali
    ali
    2012-12-18

    Hi,

    is the problem existing using a Java version 6?
    I think it's not the case, and so a first solution consist to use a jre6 instead of a 7.

    Can you attach the log file to your request?

    Sincerely yours

     
  • Yves OESCH
    Yves OESCH
    2012-12-22

    Hi Laveneau,
    I downloaded and installed jre-6u38-windows-x64.exe. I hope this is the right file, becuse there are so many things aroung Java… Installation went OK. Now I don't know if I do is right when I launch Rapsor. I simply double click on …\rapsor\rapsor\bin\rapsor.exe and still got the error windows "JMW creation failed".
    I also tried with thie following file: ..\rapsor.app\rapsor.app\contents\resources\rapsor\bin\rapsor.exe but got exactly the same error message.
    - I don't know how to provide a log file to you. Where shall I find this file?
    - Shall I start Rapsor in another way? Like launching any java related command (which/how?) and one of the many jar file inside the folder structure (which)? I must confess thT I don't know java at all.
    Thanks for your help.
    Yves

     
  • anmipo
    anmipo
    2012-12-28

    Hi,
    In my case (jdk7), the error in the console was:

    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    

    Running "

    rapsor.exe -J-Xmx1024m
    

    " solved the problem.

     
  • Yves OESCH
    Yves OESCH
    2013-01-07

    Thanks anmipo for your hint.
    I tried

     rapsor.exe -J-Xmx1024m
    

    Now Netbean environment 6.9.1 starts, and I get the main window of RaPSor. I can load a scene. I tried BarrySceneA.xml, but nothing happens. I can click on the garbage collection field. This reset the counter to about 20 MB, then it raises again to about 42.7/989.9MB, but nothing more.
    Any other Scene file to try somewhere?

    Then I wanted to see the IDE log for more help, but nothing appears anywhere. And I even cannot close RaPSor from within the program. File/exit, or clicking the top right windows cross doesn't close the window. Only way is to close the "DOS" console window. Even in this console window I don't have any output to help me find what's going wrong.

    To my opinion something is badly initialized and this causes the software not to work.
    Any hint from anybody?

    Best Regards

     
  • Yves OESCH
    Yves OESCH
    2013-01-07

    Hi again, Now it works. Sorry for the disturbance.

    I re-installed the Java 3D libraries, and this seems to have solved the problem… I had tried to install java3d-1_5_1-windows-amd64.exe and j3d-1_5_2-windows-amd64.exe
    Then I tried j3d-1_5_2-windows-i586.exe and at least I can load the BarrySceneA.xml.

    (By the way the link for downloading the 3D libraries on http://rapsor.sourceforge.net/index_fr.php?action=installation doesn't work…)

    Now it's time to learn using the software:-) Still wasn't able to display a map of the field intensity. (2D or 3D). Or maybe everything is blue because of the low field strength? I don't understand the"palette" window. I have no relation to any dB or dBm value. I'll try again to understand deeper how the software does work.
    Best Regards

     
    • WWGan
      WWGan
      2013-04-15

      Hi, I learn to use the software too. Can i ask u some questions?

      1)Have u solved the problem that everything is blue? It makes me confused.
      2)How to control 3D views?

      I'm looking forward to your reply.

      Best Regards

       
    • YSP
      YSP
      2014-12-03

      Hello Yves,
      + Could you run simulation using BarrySceneA.xml?
      + Can you elaborate which JDK, JAVA version you used and which files of RapSor? (rapsor.zip or rapsor.app)?