Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Rakarrack Does Not Start

Help
2011-02-07
2013-05-28
  • George Sprague
    George Sprague
    2011-02-07

    Hi all.  I'm a complete newb.  I'm running Ubuntu Studio 10.4 on an AMD machine with a 30GB hard drive and 2GB of RAM.  Qjackctl is started and all other programs (ZXsub, Ardour, Hydrogen, etc) all work.  My working soundcard is a USB interface, a Alesis MultiMix 4 (I'm not using the onboard audio card or the installed PCI Audigy card).  I open Jack Control, start it and then click to start Rakarrack.  The program never starts.  I'm fairly sure that all dependencies are installed.  Is there something I'm missing??

    George

     
  • Josep Andreu
    Josep Andreu
    2011-02-07

    Hi

    Please … run rakarrack on a xterm … and tell me the error message.

    Josep

     
  • George Sprague
    George Sprague
    2011-02-07

    Hi Josep,

    Here is the output… not running Jack Control at this time.

    jackd 0.118.0
    Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details

    Memory locking is unlimited - this is dangerous. You should probably alter the line:
         @audio   -  memlock    unlimited
    in your /etc/limits.conf to read:
         @audio   -  memlock    1546269
    no message buffer overruns
    JACK compiled with System V SHM support.
    loading driver ..
    apparent rate = 48000
    creating alsa driver … hw:1|hw:0|1024|3|48000|0|0|nomon|swmeter|-|32bit
    control device hw:1
    Illegal instruction
    accessdenied2@Waterwalk:~$ configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 3 periods
    ALSA: final selected sample format for capture: 16bit little-endian
    ALSA: got smaller periods 2 than 3 for capture
    ALSA: cannot configure capture channel
    cannot load driver module alsa

     
  • Transmogrifox
    Transmogrifox
    2011-02-08

    Your problem is in starting JACK.  The message about cannot load driver module alsa means it failed before jackd was even started.

    Install qjackctl and run that program.  Make modifications in the setup menu and try to start jack.  Once you are able to successfully start jackd, then rakarrack can run.  Rakarrack does not support Alsa or OSS directly, so it needs jack to work.

    Anyway, use JACK or jackd as your search term on the Ubuntu wiki.  There are some good howto's and introductory material about jackd and other audio audio systems in Linux.  This will make more sense when you begin to get familiar with how things are done…or maybe it will make less sense :)  There are so many different systems that do the same thing in Linux sometimes it causes arguments between developers - but for you - just learn about jack and that will help you start rakarrack :)

     
  • George Sprague
    George Sprague
    2011-02-09

    Hi transmogrifox,

    Thank you very much for the advice.  I'm finding this more entertaining than frustrating :-) 

    I am starting jackd, through Jack Control.  Though all other programs seem to route fine (with some crackling and snapping and xrun issues I gotta fix), rakarrack will not start.  I do not even see it in processes.  I have tried modifying settings in setup under Jack Control, with no love.  I plan to take out the Audigy card that's sitting in the computer, to see if its an IRQ issue.  Iv'e already disabled the on-board sound card.  I have a feeling rakarrack does not want to start due to the xrun issues… research indicates I either have issues with IRQ conflicts, an old/slow hard drive or just a processor/motherboard that is too old.  2GB of RAM should be enough…

    Thank you again,

    George

     
  • Transmogrifox
    Transmogrifox
    2011-02-09

    The output from the terminal was strange - it is the output you get when Rakarrack does not recognize a running instance of jack server, then tries to start it.  Are you running jack as root, then starting rakarrack as a user? 

    Also, maybe you can try starting rakarrack with a different default preset.  I thiink the first one it starts with is Rodent Airlines,which uses lots of CPU.  Umh… Try
    $rakarrack -p 9

    That will load a preset that doesn't eat too much cpu - so that can eliminate one possible problem.

    If other jack applications are working with jack (and show up in the routing) then should be good.

    The thing is, the ALSA window of qjackctl will show these devices if they are connected using ALSA directly, and not using jack.  They should all be present in the Audio tab if jack is being used.

    2GB ram is more than enough.  Rakarrack doesn't use much RAM.  Most effects hardly use any CPU, but things like Reverbtron, Harmonizer, and Convolotron use CPU like crazy.  Avoid those effects if you have old or slower hardware.

     
  • mistermusix
    mistermusix
    2012-03-09

    Hello all,

    I came across the very same thing as the original poster.
    Fact is, in this case, the machine is correct when saying "Illegal instruction", since the packaged version of Rakarrack is compiled with SSE2 command set support, which obviously doesn't work when your CPU does not feature an SSE2 unit.
    Athlon XP only has SSE, not SSE2. Solution is to reconfigure and recompile the package *on your own system*.
    Then it will build without SSE2 support and run correctly afterwards.
    This is a bug in Ubuntu distribution.

    MisterMusix

     
  • Transmogrifox
    Transmogrifox
    2012-03-11

    Thanks MisterMusix.  I didn't catch the line in the output "illegal instruction".  I see it now upon closer investigation.

    Your explanation sounds likely.  GCC documentation mentions the following about these options:

    "These options enable GCC to use these extended instructions in generated code, even without -mfpmath=sse. Applications that perform run-time CPU detection must compile separate files for each supported architecture, using the appropriate flags. In particular, the file containing the CPU detection code should be compiled without these options. "

    This is a somewhat clunky way to distribute Rakarrack, so it's probably better if package maintainers make the decision about how to distribute Rakarrack (for example, there could be two different packages, "rakarrack", "rakarrack-noSSE", etc.

    So the best advice is to compile your own.

    If you compile your own rakarrack, then perhaps you should use the git repository for new and interesting things, instead of the last release.