#21 Condition - strange behaviour

closed-wont-fix
Rafal Tomczak
Interface (10)
5
2011-09-02
2011-08-30
MarcinK
No

If you set some conditions (i. e. "Fmode 1"="Yes", Fmode 2="No") and go to another screen, conditions stay on the screen (Now you can see "GEAR"="Yes", "TRN"="No")

Discussion

  • Rafal Tomczak
    Rafal Tomczak
    2011-09-01

    • status: open --> closed-fixed
     
  • Rafal Tomczak
    Rafal Tomczak
    2011-09-01

    It was by design... but I change it as You wish.

    fixed in 0.073

     
  • MarcinK
    MarcinK
    2011-09-02

    I'm afraid I can't set condition i. e. "Fmode 1"="Yes" & "GEAR"="No" due this.
    I was trying to set flaps (on Fmode) and airbrake (on GEAR), which can't be activated simultaneously.

     
  • MarcinK
    MarcinK
    2011-09-02

    • status: closed-fixed --> open-fixed
     
  • Rafal Tomczak
    Rafal Tomczak
    2011-09-02

    • status: open-fixed --> closed-wont-fix
     
  • Rafal Tomczak
    Rafal Tomczak
    2011-09-02

    sorry :( I didn't understand Your requirement...
    I fixed problem which caused not to clear setting when condition mode was changed from one mode to another.

    The "bug" You described won;t be fixed, because is this behaviour is ok, and it was done such way by design.

    Condition can work only in one mode: state condition or switch condition. You can't use both of them.

    If You want to combine both condition (state and switch), then different definition of "states" are needed. State machine rules can check additional condition, so you can use other state to hold your state+switch condition, and then use it in mixers. Maybe it will be enough to redefine current "state" changing rules?