Hi,

 

Building with Qt 4.8 CsoundQt works fine with MIDI, building against qt 5.3 fails with many errors like:

 

/usr/include/qt5/QtWidgets/QApplication:1: In file included from /usr/include/qt5/QtWidgets/QApplication:1:0,

/home/tarmo/src/qutecsound/build-qcs-Qt_5_3-Debug/build/ui/ui_about.h:14: from build/ui/ui_about.h:14,

/home/tarmo/src/qutecsound/qutecsound-code/src/about.cpp:24: from ../qutecsound-code/src/about.cpp:24:

/usr/include/qt5/QtWidgets/qapplication.h:111: error: missing binary operator before token "("

 

The line causing the error is (qapplication.h):

 

#if QT_DEPRECATED_SINCE(5, 0)

QT_DEPRECATED static inline void setGraphicsSystem(const QString &) {}

#endif

 

There must be something wrong in my settings, but do you have ezperinece, what can it be?

 

qmake does report lines

 

Project MESSAGE: + QCS_QT5

Project MESSAGE: + QCS_QT53

 

Thanks!

tarmo

 

On Friday 20 June 2014 10:07:09 Andres Cabrera wrote:

> Hi,

>

> I'd like to ask if people are still experiencing issues with MIDI input

> stability. I have made a few fixes that solved a few issues, and all I can

> say is it works for me :).

>

> But I'd like to hear if people are still experiencing problems, and under

> what particular conditions.

>

> Cheers,

> Andrés