#66 Widgets disappear from widget panel when switching computers

closed-invalid
nobody
None
5
2010-08-24
2010-08-24
composer
No

The attached file works as expected on a Mac Pro, OSX5.8, with 2 monitors (approximately 20 inches each.) The main QTSC window (containing editor, inspector and console) appears in the monitor to my left, the widget panel is positioned in the monitor to my right, which also includes the OSX menubar. When I copy this csd and its environment to my Mac Book, which has a single screen, the widget panel appears on the screen but no widgets are visible. The size of the blank widget panel does not match the size as it appears on my Mac Pro. Entering widget edit mode makes no difference. Running the csd makes no difference. The csd, which depends in part on the widgets, does not make any sound.
Many previous versions of this same csd transferred with no problems from my large computer to my laptop. As I have a performence tomorrow, in desperation I was able to run this new csd with MacCsound! thankfully, the oldstyle widget text is still included in the csd.

Discussion

  • composer
    composer
    2010-08-24

     
  • Andres Cabrera
    Andres Cabrera
    2010-08-24

    Sorry to hear that at such a bad moment...
    The file works fine on Linux. And I don't see anything odd about it.
    Are you certain you have the same version of QuteCsound installed on both systems (maybe you have beta on one and release on the other?
    Can you try on the single screen system opening any other csd, docking the widget panel, and with it docked loading the file that is problematic?

    Can you create widgets on the widget panel? What happens if you create a widget, then save the file and then reopen it?

    What happens if you remove the new widget text from the file in a text editor and reload the file. Are the widgets back? If you save the file, are they OK when it is reloaded?

    It is really a mystery as I don't see anything that could be causing this...

     
  • composer
    composer
    2010-08-24

    Andres,
    Thanks for responding quickly. The problem was indeed the use of the wrong version of QTCS. I had forgotten to delete the older version when I installed the current version. Both versions were on my system. Sorry to cause trouble. There is an interesting but not very serious problem, which I will report in a separate posting (regarding resizing of the widget panel.)

     
  • Andres Cabrera
    Andres Cabrera
    2010-08-24

    • status: open --> closed-invalid
     
  • Andres Cabrera
    Andres Cabrera
    2010-08-24

    I'm glad it wasn't serious.