dependent variable as x-axis

Help
Anonymous
2011-09-03
2012-12-15

  • Anonymous
    2011-09-03

    Is it possible to get x/y plots where x and y are dependent variables? For instance consider this example: http://sourceforge.net/apps/mediawiki/qucs/index.php?title=Parameter_Sweep

    Is it possible to get a plot where out.V is the y-axis and IProbe.I is the x-axis?

     
  •  magneto98
    magneto98
    2011-09-04

    Hi qucsnewbie,

    you mean like this:

    <Qucs Schematic 0.0.16>
    <Properties>
      <View=150,-20,1382,873,0.79148,0,0>
      <Grid=10,10,1>
      <DataSet=forum_dependent variable as x-axis2.dat>
      <DataDisplay=forum_dependent variable as x-axis2.dpl>
      <OpenDisplay=0>
      <Script=forum_dependent variable as x-axis2.m>
      <RunScript=0>
      <showFrame=0>
      <FrameText0=Title>
      <FrameText1=Drawn By:>
      <FrameText2=Date:>
      <FrameText3=Revision:>
    </Properties>
    <Symbol>
    </Symbol>
    <Components>
      <GND * 1 760 480 0 0 0 0>
      <.DC DC1 1 200 400 0 61 0 0 "26.85" 0 "0.001" 0 "1 pA" 0 "1 uV" 0 "no" 0 "150" 0 "no" 0 "none" 0 "CroutLU" 0>
      <Vdc V1 1 600 400 18 -26 0 1 "Vg" 1>
      <R R1 1 700 330 -26 15 0 0 "10 Ohm" 1 "26.85" 0 "0.0" 0 "0.0" 0 "26.85" 0 "european" 0>
      <R R2 1 980 420 15 -26 0 1 "10 Ohm" 1 "26.85" 0 "0.0" 0 "0.0" 0 "26.85" 0 "european" 0>
      <IProbe Pr1 1 920 330 -26 16 0 0>
      <Eqn Eqn1 1 1140 290 -31 17 0 0 "dep_variable=PlotVs(out.V,Pr1.I)" 1 "yes" 0>
      <.SW SW1 1 220 560 0 73 0 0 "DC1" 1 "lin" 1 "Vg" 1 "1" 1 "10" 1 "5" 1>
    </Components>
    <Wires>
      <600 480 760 480 "" 0 0 0 "">
      <600 430 600 480 "" 0 0 0 "">
      <760 480 980 480 "" 0 0 0 "">
      <980 330 980 390 "" 0 0 0 "">
      <600 330 670 330 "" 0 0 0 "">
      <600 330 600 370 "" 0 0 0 "">
      <980 450 980 480 "" 0 0 0 "">
      <730 330 890 330 "" 0 0 0 "">
      <950 330 980 330 "" 0 0 0 "">
      <980 330 980 330 "out" 1010 300 0 "">
    </Wires>
    <Diagrams>
      <Rect 590 770 240 160 3 #c0c0c0 1 00 1 -1 0.5 1 1 -1 1 1 1 -1 1 1 315 0 225 "" "" "">
    <"dep_variable" #0000ff 0 3 0 0 0>
      </Rect>
      <Tab 220 164 213 144 3 #c0c0c0 1 00 1 0 1 1 1 0 1 1 1 0 1 20 315 0 225 "" "" "">
    <"out.V" #0000ff 0 3 1 0 0>
    <"Pr1.I" #0000ff 0 3 1 0 0>
      </Tab>
      <Tab 730 149 253 139 3 #c0c0c0 1 00 1 0 1 1 1 0 1 1 1 0 1 5 315 0 225 "" "" "">
    <"dep_variable" #0000ff 0 3 1 0 0>
      </Tab>
    </Diagrams>
    <Paintings>
    </Paintings>

    Carsten

     
  •  magneto98
    magneto98
    2011-09-04

    Copy paste of the schematic data doesn't work for me, so here the data again on pastebin:

    http://pastebin.com/yq09fxRV
    Carsten

     

  • Anonymous
    2011-09-05

    Thanks. I have to test it. Do I need to install 0.0.16 or does this work in my version (0.0.15) equally well?

     
  •  magneto98
    magneto98
    2011-09-05

    It should work with both versions