Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#129 Mac package, add -macosx-version-min=10.5 throughout. Still problems.

0.0.18
closed
Guilherme
None
5
2014-08-04
2013-10-23
Guilherme
No

The Mac package is being compiled (by me) on OS X 10.8.5, however it was crashing on 10.6.

The GUI seems to be working just buy adding the macosx-version-min=10.6 along CFLAGS, CXXFLAGS and LDFLAGS.

Lowering to 10.5 only works if the Clang compiler is used. Using GCC leads to a std:: error In qf_filter.cpp, similar to the one described in [1]. The reason to go as low as 10.5 is that Qt also supports this version of OSX (on intel 64 machines).

So, compiling with Clang and setting it to 10.5 compilation wise it works.

The user Alex with 10.6 is reporting [2] that with the above configuration the GUI is ok but simulations are crashing.

As a side note: using Qt compiled by me also lead to problems to end users. I believe it was mostly due to permission mismatches while deploying the package. I switched back to using the official Qt binaries and this problem seems to be resolved.

[1] https://bugreports.qt-project.org/browse/QTBUG-26734
[2] https://sourceforge.net/p/qucs/discussion/311050/thread/d84fe5cc/

Discussion

  • Guilherme
    Guilherme
    2014-08-04

    • status: open --> closed
     
  • Guilherme
    Guilherme
    2014-08-04

    Should be resolved with the added support for SDK (configure.ac). It detect (user can change) the available SDK versions and set the proper compiler flags.