Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#155 Can't connect any database bookmarks

open
nobody
None
5
2014-08-17
2008-01-09
gamnascimento
No

First time I create a bookmark, quantum db works correctly. After closing my workspace and opening it again, any bookmark seems to work, and I get the exception in the workspace log.

I'm using IBM RAD 7.

Thanks!

!ENTRY org.eclipse.ui 4 0 2008-01-09 07:44:08.106
!MESSAGE $Proxy1 incompatible with java.sql.Connection
!STACK 0
java.lang.ClassCastException: $Proxy1 incompatible with java.sql.Connection
at com.quantum.util.proxy.ProxyFactory.createConnectionProxy(Unknown Source)
at com.quantum.util.proxy.ProxyFactory$DriverInvocationHandler.handleSpecial(Unknown Source)
at com.quantum.util.proxy.ProxyFactory$InvocationHandlerImpl.invoke(Unknown Source)
at $Proxy0.connect(Unknown Source)
at com.quantum.model.ConnectionEstablisherImpl.connect(Unknown Source)
at com.quantum.model.ConnectionEstablisherImpl.connect(Unknown Source)
at com.quantum.model.Bookmark.connect(Unknown Source)
at com.quantum.ui.dialog.ConnectionUtil.connect(Unknown Source)
at com.quantum.view.SchemaSelectionControl.addSchema(Unknown Source)
at com.quantum.view.SchemaSelectionControl.access$1(Unknown Source)
at com.quantum.view.SchemaSelectionControl$4.widgetSelected(Unknown Source)
at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.eclipse.jface.window.Window.runEventLoop(Unknown Source)
at org.eclipse.jface.window.Window.open(Unknown Source)
at org.eclipse.ui.dialogs.PropertyDialogAction.run(Unknown Source)
at org.eclipse.jface.action.Action.runWithEvent(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem.access$2(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.eclipse.ui.internal.Workbench.runEventLoop(Unknown Source)
at org.eclipse.ui.internal.Workbench.runUI(Unknown Source)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Unknown Source)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(Unknown Source)
at org.eclipse.ui.internal.ide.IDEApplication.run(Unknown Source)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(Unknown Source)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(Unknown Source)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Unknown Source)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Unknown Source)
at org.eclipse.core.launcher.Main.basicRun(Unknown Source)
at org.eclipse.core.launcher.Main.run(Unknown Source)
at org.eclipse.core.launcher.Main.main(Unknown Source)

Discussion

  • Julen Parra
    Julen Parra
    2008-01-09

    Logged In: YES
    user_id=180901
    Originator: NO

    So if I understand it correctly, you could access your data if you created a bookmark every time you wanted to use one. The error seems to be perhaps in the saving and/or restoring of the bookmark data. Do the bookmarks seem any different if you expand them (using the Properties in the context menu), after being saved-restored?

    In any case I think that could be a Java version problem, or some kind of Eclipse corruption. Could you tell me your environment (JVM version, Quantum version, OS, etc). You could also try installing Quantum out of RAD, in a normal Eclipse environment with Java 1.4 or later, to see if you have the same problem. Also, searching for the saved files of Quantum (should be in .metadata/.plugins/com.quantum.Quantum directory), and having a look to see if everything looks ok, could help.

    Good vibes.