Does NOT work 1.0d7 + Pather + QT 6.5

Help
Ed
2004-03-30
2004-04-21
  • Ed
    Ed
    2004-03-30

    I have OSX 10.3.3, QT 6.5.  I copied OggVorbis.component to /Library/Quicktime folder.  When I try to play an ogg song in iTunes 4.2, it simply skips over the song.  I noticed that some other posters have reported success.  What am I doing wrong?  I can play these ogg files in VLC, but not in anything QT related.

    Ed

     
    • Steve Nicolai
      Steve Nicolai
      2004-03-30

      Try opening the ogg file with QuickTime Player.  Does it work?  What error message does it give you?

       
      • Ed
        Ed
        2004-03-30

        When I open the ogg file in QT Player, the file loads, but the song never plays.  It was as if the song was of 0 length.  I see no error message.

         
    • Same here, when I load new ogg songs in iTunes, it says "Not available" in the Time column, and immediately moves to the next song when trying to play it. Strangely enough, the existing ogg songs in my library play fine. QT Player also refuses to play ogg files. It only shows the tags in the info window, but not the song length, format or any other info.

       
      • Update: it appears that most of my songs have no problems. But one song consistently refuses to play, while this was not the case with the previous version. It may be a coincidence, but this is a song which has a special character () in its vorbis tags. If you want, I can put it online for testing, otherwise I'll try to do some debugging myself if I ever have the time.

         
    • Hugo Forss
      Hugo Forss
      2004-04-01

      i'm having sort of the same problem in MacOS 10.2.8. when i try to preview an ogg in the Finder it appears as having zero-length and pressing the play button does nothing.

       
    • Hugo Forss
      Hugo Forss
      2004-04-01

      hmm, same for me - most of my songs work just fine. it seems as if only the most recent ones are posing any trouble.
      but they do not contain any strange characters, and they are all encoded with the same version of oggdrop (1.0b3.1). the only thing they have in common is being the most recently encoded files. i have no idea what it is that i've done (or not done) to make them not play at all.

       

    • Anonymous
      2004-04-03

      I tried to use 1.0d7 with Panther OSX 10.3.5 and QT 6.5 without success.  I have tried to use it for streaming audio.  It just hangs up iTunes and I have to force quit it.  However, I read somewhere that this plugin does not work with streaming audio.  I have not tried it on individual files.

       
    • I used VorbisRage to change the tags on some ogg vorbis files which worked fine with this QT component and iTunes, after just updating the tags iTunes says 'not available' for the track time - and just doesn't play it.