#85 Support for ezmlm-idx 7.0.0

open
nobody
Broken (26)
5
2009-11-20
2009-11-20
Anonymous
No

When installing on a system with ezmlm-idx 7.0.0 a number of features appear to be broken...

The list configs are upgraded from ezmlm-idx 0.40-r2 and when first loading them, qmailadmin appears to load the details correctly, but subsequently saving and reloading it is unable to load the config from the format ezmlm-idx 7.0.0 saves it in...

I changed the b/g options for moderator/subscriber retrieval of archives to read the new modgetonly/subgetonly files:

sprintf(TmpBuf, "%s/modgetonly", ActionUser);
checkopt['b'] = file_exists(TmpBuf);

sprintf(TmpBuf, "%s/subgetonly", ActionUser);
checkopt['g'] = file_exists(TmpBuf);

but there seems to be many other things which are broken...

what is the recommended version of ezmlm-idx to use with qmailadmin, and is there any eta to support the current versions?

Discussion

  • Tom Collins
    Tom Collins
    2009-11-21

    QmailAdmin only understands the older ezmlm-idx 0.4x releases. You could ask around on the QmailAdmin mailing lists (qmailadmin@inter7.com -- to subscribe, email qmailadmin-subscribe@inter7.com) to see if anyone would be interested in making the updates.