Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#83 Installation Error ?

open
nobody
5
2007-09-19
2007-09-19
Anonymous
No

I use Fedora 7 as an Operationg System, qmailadmin-1.2.11, vpopmail-5.4.22, when I start to install, there is a problem :

make all-am
make[1]: Entering directory `/usr/local/src/qmailadmin-1.2.11'
source='qmailadmin.c' object='qmailadmin.o' libtool=no \ depfile='.deps/qmailadmin.Po' tmpdepfile='.deps/qmailadmin.TPo' \ depmode=gcc3 /bin/sh ./depcomp \ gcc -I. -I/home/vpopmail/include -I. -I. -I. -DHAVE_OPEN_SMTP_RELAY -DHAVE_VLOGAUTH -Wall -c `test -f 'qmailadmin.c' || echo './'`qmailadmin.c
In file included from qmailadmin.c:49:
qmailadmin.h:66: error: conflicting types for âreaduserquotaâ
/home/vpopmail/include/vpopmail.h:219: error: previous declaration of âreaduserquotaâ was here
make[1]: *** [qmailadmin.o] Error 1
make[1]: Leaving directory `/usr/local/src/qmailadmin-1.2.11'
make: *** [all] Error 2

Discussion

  • odeneriksson
    odeneriksson
    2007-09-21

    Logged In: YES
    user_id=1894348
    Originator: NO

    remove the "int readuserquota(const char* dir, long *sizep, int *cntp);" line in qmailadmin.h (the last line)

     
  • Tom Collins
    Tom Collins
    2007-09-21

    Logged In: YES
    user_id=117662
    Originator: NO

    Consider that a temporary solution. Rick is rolling back the change he made to vpopmail that causes that error. Wait for and try 5.4.23 when it's released.