Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#5 configure doesn't grok Qt 2.3.1

closed-works-for-me
nobody
None
5
2002-06-07
2002-03-09
Anonymous
No

I am trying to build qfsm-0.30 on a RedHat 7.2 system
with gcc/g++ 3.0.4 . I have qt installed in
/usr/lib/qt-2.3.1/lib (libraries) and
/usr/lib/qt-2.3.1/include (includes); in the lib
directory there are libqt-mt.a, libqt-mt.so.2.3.1,
libqt.so.2.3, libqutil.so.1.0, libqt-mt.so, libqt.a,
libqt.so.2.3.1, libqutil.so.1.0.0,
libqt-mt.so.2, libqt.so, libqutil.so, libqxt.a,
libqt-mt.so.2.3, libqt.so.2 andlibqutil.so.1. Running
'configure' with
./configure --with-qt-dir=/usr/lib/qt-2.3.1
--with-qt-includes=/usr/lib/qt-2.3.1/include
--with-qt-libraries=/usr/lib/qt-2.3.1/lib
I get the following error:
...
checking for libjpeg... -ljpeg
checking for Qt... configure: error: Qt (>= Qt 2.2.2)
(libraries) not found. Please check your installation!
For more details about this problem, look at the end of
config.log. tail config.log shows:
#define SIZEOF_INT 4
#define SIZEOF_LONG 4
#define SIZEOF_CHAR_P 4
#define SIZEOF_CHAR 1
#define HAVE_LIBZ 1
#define HAVE_LIBPNG 1
#define HAVE_LIBJPEG 1

configure: exit 1
(extremely interesting :-). Any hint to make configure
recognize a properly installed Qt version 2.3.1?

TIA, Maurizio <loreti@pd.infn.it>

Discussion

  • Stefan Duffner
    Stefan Duffner
    2002-06-07

    • status: open --> closed-works-for-me