ImportError - Bug in ZSI???

2009-08-28
2013-05-02
  • John Benner
    John Benner
    2009-08-28

    Hi,
        I'm using latest ZSI 2.1-a1.tar.gz on Debian OS. I've downloaded Python 2.6.2 However, when I run my client program, it gives below error:

      File "/usr/local/lib/python2.6/site-packages/ZSI/__init__.py", line 152, in <module>
        from ZSI.wstools.Namespaces import ZSI_SCHEMA_URI
      File "/usr/local/lib/python2.6/site-packages/ZSI/wstools/__init__.py", line 6, in <module>
        import WSDLTools
      File "/usr/local/lib/python2.6/site-packages/ZSI/wstools/WSDLTools.py", line 15, in <module>
        from Utility import Collection, CollectionNS, DOM, ElementProxy, basejoin
      File "/usr/local/lib/python2.6/site-packages/ZSI/wstools/Utility.py", line 24, in <module>
        from httplib import HTTPConnection, HTTPSConnection
    ImportError: cannot import name HTTPSConnection

    I tried installing older version but no luck. I tried installing using package manager but still same error.

    Is it a bug in ZSI???

    Thanks!