Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Cannot install pythonflu on Ubuntu 12.04x86

Help
sangram
2012-10-25
2013-08-29
  • sangram
    sangram
    2012-10-25

    First of all thanks for this wonderful tool, it is exactly what I wanted (I was searching for something that couples Salome and OF) when I found pyflu.
    However, I just cannot get it to install on my system.
    My System is:-
    Ubuntu 12.04 32 bits
    Openfoam 1.6 ext and Openfoam 2.1.0
    python 2.7 + python dev (2.7)
    1. I installed Openfoam (both versions) through source hence synaptic does not recognize openfoam as being installed (when I tried installing the deb package for pythonflu from precise launchpad - it has version for 211 only i guess as it reports pythonfoam210 not found).
    2. Since I have a very moderate experience of compiling under linux i tried the pythonflu source, i installed conflu first which was not issue. then edited the env.sh file in the pythonflu source to fit my needs. next ./build-configure which worked well, however when I go on to ./configure, it reports that python-dev is missing. It does find python.h file but just cannot locate the dev libraries.
    I am stuck in this step and any help will be appreciated.
    Thanks in advance.
    Sangram P.
    I try installing

     
  • sangram
    sangram
    2012-10-25

    Hey Alexey,
    Thanks for the reply. I will try out the packages and let you know.

    I had some working devel at 2.1.0 hence didnt switch over to 2.1.1. anyways if the packages dont work, will move onto the 2.1.1 and try out the apt-get from the ppa.

    As a side note, I really do appreciate your work, and would like to help/assist/contribute in some way. I agree it will take me some time to get hands on with the code, but I can definitely help in my spare time in creating docs/tutorials/etc, do let me know if thats alright…
    Thanks a tonne…
    sangram P.

     
  • Alexey Petrov
    Alexey Petrov
    2012-10-25

    Hey sangram,

    Glad you liked pythonFlu and would like to "help/assist/contribute" for the "creating docs/tutorials". That is especially what we are desperately in need and it will be really great help for us. You could contact me by e-mail address you could find in pythonFlu sources.

    Best regards,
    Alexey

     
  • sangram
    sangram
    2012-10-25

    Sure will
    I will send you a mail to that effect…

     
  • sangram
    sangram
    2012-10-25

    I will let you know how the installation goes.
    Thanks.

     
  • Jon
    Jon
    2013-08-29

    Hi Alexey,
    I'm trying to use the Ubuntu .deb files to install via apt-get and it tries to installed openfoam211 in the process. I've got openfoam2.1.x compiled via a git repository -- is it possible to install via apt-get but make it point to my installed version of OF?

    edit: Ubuntu 12.10

     
    Last edit: Jon 2013-08-29