First, is this possible? I see there are only binary installers up to version 2.4.

I tried to download the platform independent pyPgSQL. I built and installed it. The results of the build were:

running build
running build_py
running build_ext
building 'pyPgSQL.libpq.libpq' extension
error: None

I don't know if Error:None means success, or if it's an error without any other info.

I can import pyPgSQL.

When I try to import libpq from pyPgSQL I get an error in the "from libpq import *" line of the __init__ file of my libpq package.

I have added a path to the lib and bin dirs of my postPres installation, this is where libpq.dll resides.

I am lost, any help greatly appreciated.

Ted