Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#70 ParseBaseException.markInputline()

v1.0 (example)
closed
Paul McGuire
None
5
2014-04-13
2014-04-09
Matt Grant
No

A call to CPython str.join(), line 207, is missing '()' or '[]' around the arguments. My program blows up when dealing with errors:

File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
print(exc.markInputline(), file=self.stdout)
File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in markInputline
markerString, line_str[line_column:])
TypeError: join() takes exactly one argument (3 given)

Patch attached

1 Attachments

Related

Bugs: #70

Discussion

  • Paul McGuire
    Paul McGuire
    2014-04-09

    Thanks, Matt! I just fixed this in SVN if you want to get it from there, or
    wait until this evening when I get a chance to push out a new release (it's
    been quite a few months, I was just waiting to see what other fallout there
    might have been from my merger of 2.6, 2.7, and 3.x support into a single
    release).

    -- Paul

    From: Matt Grant [mailto:mattgrant@users.sf.net]
    Sent: Wednesday, April 09, 2014 3:35 AM
    To: Ticket 70
    Subject: [pyparsing:bugs] #70 ParseBaseException.markInputline()


    [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
    ParseBaseException.markInputline()

    Status: open
    Group: v1.0 (example)
    Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
    Last Updated: Wed Apr 09, 2014 08:34 AM UTC
    Owner: nobody

    A call to CPython str.join(), line 207, is missing '()' or '[]' around the
    arguments. My program blows up when dealing with errors:

    File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
    print(exc.markInputline(), file=self.stdout)
    File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
    markInputline
    markerString, line_str[line_column:])
    TypeError: join() takes exactly one argument (3 given)

    Patch attached


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/pyparsing/bugs/70/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/


    This email is free from viruses and malware because avast! Antivirus protection is active.
    http://www.avast.com

     

    Related

    Bugs: #70

    Attachments
    • Matt Grant
      Matt Grant
      2014-04-09

      FYI, the documentation for 2.6, 2.7, and 3.3 say the argument to
      str.join() should be an iterable, so this fix should work everywhere.

      On Wed, 2014-04-09 at 14:15 +0000, Paul McGuire wrote:

      Thanks, Matt! I just fixed this in SVN if you want to get it from
      there, or
      wait until this evening when I get a chance to push out a new release
      (it's
      been quite a few months, I was just waiting to see what other fallout
      there
      might have been from my merger of 2.6, 2.7, and 3.x support into a
      single
      release).

      -- Paul

      From: Matt Grant [mailto:mattgrant@users.sf.net]
      Sent: Wednesday, April 09, 2014 3:35 AM
      To: Ticket 70
      Subject: [pyparsing:bugs] #70 ParseBaseException.markInputline()


      [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
      ParseBaseException.markInputline()

      Status: open
      Group: v1.0 (example)
      Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
      Last Updated: Wed Apr 09, 2014 08:34 AM UTC
      Owner: nobody

      A call to CPython str.join(), line 207, is missing '()' or '[]' around
      the
      arguments. My program blows up when dealing with errors:

      File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
      print(exc.markInputline(), file=self.stdout)
      File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
      markInputline
      markerString, line_str[line_column:])
      TypeError: join() takes exactly one argument (3 given)

      Patch attached


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/pyparsing/bugs/70/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/


      This email is free from viruses and malware because avast! Antivirus
      protection is active.
      http://www.avast.com


      [bugs:#70] ParseBaseException.markInputline()

      Status: open
      Group: v1.0 (example)
      Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
      Last Updated: Wed Apr 09, 2014 08:34 AM UTC
      Owner: nobody

      A call to CPython str.join(), line 207, is missing '()' or '[]' around
      the arguments. My program blows up when dealing with errors:

      File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
      print(exc.markInputline(), file=self.stdout)
      File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
      markInputline
      markerString, line_str[line_column:])
      TypeError: join() takes exactly one argument (3 given)

      Patch attached


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/pyparsing/bugs/70/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #70

      • Paul McGuire
        Paul McGuire
        2014-04-09

        Yes, I already confirmed that with updated unit tests.

        -- Paul

        From: Matt Grant [mailto:mattgrant@users.sf.net]
        Sent: Wednesday, April 09, 2014 2:46 PM
        To: [pyparsing:bugs]
        Subject: [pyparsing:bugs] Re: #70 ParseBaseException.markInputline()

        FYI, the documentation for 2.6, 2.7, and 3.3 say the argument to
        str.join() should be an iterable, so this fix should work everywhere.

        On Wed, 2014-04-09 at 14:15 +0000, Paul McGuire wrote:

        Thanks, Matt! I just fixed this in SVN if you want to get it from
        there, or
        wait until this evening when I get a chance to push out a new release
        (it's
        been quite a few months, I was just waiting to see what other fallout
        there
        might have been from my merger of 2.6, 2.7, and 3.x support into a
        single
        release).

        -- Paul

        From: Matt Grant [mailto:mattgrant@users.sf.net]
        Sent: Wednesday, April 09, 2014 3:35 AM
        To: Ticket 70
        Subject: [pyparsing:bugs] #70 ParseBaseException.markInputline()


        [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
        http://sourceforge.net/p/pyparsing/bugs/70/
        ParseBaseException.markInputline()

        Status: open
        Group: v1.0 (example)
        Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
        Last Updated: Wed Apr 09, 2014 08:34 AM UTC
        Owner: nobody

        A call to CPython str.join(), line 207, is missing '()' or '[]' around
        the
        arguments. My program blows up when dealing with errors:

        File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
        print(exc.markInputline(), file=self.stdout)
        File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
        markInputline
        markerString, line_str[line_column:])
        TypeError: join() takes exactly one argument (3 given)

        Patch attached


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/pyparsing/bugs/70/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/


        This email is free from viruses and malware because avast! Antivirus
        protection is active.
        http://www.avast.com


        [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
        ParseBaseException.markInputline()

        Status: open
        Group: v1.0 (example)
        Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
        Last Updated: Wed Apr 09, 2014 08:34 AM UTC
        Owner: nobody

        A call to CPython str.join(), line 207, is missing '()' or '[]' around
        the arguments. My program blows up when dealing with errors:

        File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
        print(exc.markInputline(), file=self.stdout)
        File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
        markInputline
        markerString, line_str[line_column:])
        TypeError: join() takes exactly one argument (3 given)

        Patch attached


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/pyparsing/bugs/70/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/


        [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
        ParseBaseException.markInputline()

        Status: open
        Group: v1.0 (example)
        Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
        Last Updated: Wed Apr 09, 2014 08:34 AM UTC
        Owner: nobody

        A call to CPython str.join(), line 207, is missing '()' or '[]' around the
        arguments. My program blows up when dealing with errors:

        File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
        print(exc.markInputline(), file=self.stdout)
        File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
        markInputline
        markerString, line_str[line_column:])
        TypeError: join() takes exactly one argument (3 given)

        Patch attached


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/pyparsing/bugs/70/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/


        This email is free from viruses and malware because avast! Antivirus protection is active.
        http://www.avast.com

         

        Related

        Bugs: #70

        Attachments
  • Paul McGuire
    Paul McGuire
    2014-04-13

    Fixed in 2.0.2

     
  • Paul McGuire
    Paul McGuire
    2014-04-13

    • status: open --> closed
    • assigned_to: Paul McGuire
     
    • Matt Grant
      Matt Grant
      2014-04-13

      Thanks Paul!

      Will get the Debian Packager to turn his wheels ;-)

      Cheers,

      Matt Grant

      On Sun, 2014-04-13 at 17:29 +0000, Paul McGuire wrote:

        * status: open --> closed
        * assigned_to: Paul McGuire
        * Comment:
      

      Fixed in 2.0.2


      [bugs:#70] ParseBaseException.markInputline()

      Status: closed
      Group: v1.0 (example)
      Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
      Last Updated: Wed Apr 09, 2014 08:34 AM UTC
      Owner: Paul McGuire

      A call to CPython str.join(), line 207, is missing '()' or '[]' around
      the arguments. My program blows up when dealing with errors:

      File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
      print(exc.markInputline(), file=self.stdout)
      File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
      markInputline
      markerString, line_str[line_column:])
      TypeError: join() takes exactly one argument (3 given)

      Patch attached


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/pyparsing/bugs/70/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #70

  • Paul McGuire
    Paul McGuire
    2014-04-13

    I just pushed out release 2.0.2, which should address this bug.

    Thanks for reporting!

    -- Paul

    From: Matt Grant [mailto:mattgrant@users.sf.net]
    Sent: Wednesday, April 09, 2014 3:35 AM
    To: Ticket 70
    Subject: [pyparsing:bugs] #70 ParseBaseException.markInputline()


    [bugs:#70] http://sourceforge.net/p/pyparsing/bugs/70/
    ParseBaseException.markInputline()

    Status: open
    Group: v1.0 (example)
    Created: Wed Apr 09, 2014 08:34 AM UTC by Matt Grant
    Last Updated: Wed Apr 09, 2014 08:34 AM UTC
    Owner: nobody

    A call to CPython str.join(), line 207, is missing '()' or '[]' around the
    arguments. My program blows up when dealing with errors:

    File "/usr/share/dms/dms/app/zone_tool.py", line 2251, in do_edit_zone
    print(exc.markInputline(), file=self.stdout)
    File "/usr/lib/python3/dist-packages/pyparsing.py", line 207, in
    markInputline
    markerString, line_str[line_column:])
    TypeError: join() takes exactly one argument (3 given)

    Patch attached


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/pyparsing/bugs/70/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/


    This email is free from viruses and malware because avast! Antivirus protection is active.
    http://www.avast.com

     

    Related

    Bugs: #70

    Attachments