#65 'pip install pyparsing' fails on Python 2.x

open
nobody
None
5
2013-07-09
2013-04-17
Glyph Lefkowitz
No

2.0.0 only works on 3.x, which is not in wide use yet; users of 2.x need to know that they need to specify an exact version (i.e. 'pip install pyparsing==1.5.5')

There's a trove classifier for "Programming Language :: Python :: 2 :: Only"; perhaps "Programming Language :: Python :: 3 :: Only" could indicate to PyPI that this package doesn't work?

Here's what happens when I try it:

Downloading/unpacking pyparsing from https://pypi.python.org/packages/source/p/pyparsing/pyparsing-2.0.0.zip#md5=f9bc56d9f6c977085001db49a63d7bb9
Downloading pyparsing-2.0.0.zip (1.3MB): 1.3MB downloaded
Running setup.py egg_info for package pyparsing
Traceback (most recent call last):
File "<string>", line 16, in <module>
File "/private/var/folders/wd/y0p85qd48xx992w8rkclf7mc8xdc8d/T/pip-build-glyph/pyparsing/setup.py", line 9, in <module>
from pyparsing import __version__ as pyparsing_version
File "pyparsing.py", line 629
nonlocal limit,foundArity
^
SyntaxError: invalid syntax
Complete output from command python setup.py egg_info:
Traceback (most recent call last):

File "<string>", line 16, in <module>

File "/private/var/folders/wd/y0p85qd48xx992w8rkclf7mc8xdc8d/T/pip-build-glyph/pyparsing/setup.py", line 9, in <module>

from pyparsing import __version__ as pyparsing_version

File "pyparsing.py", line 629

nonlocal limit,foundArity

^

SyntaxError: invalid syntax

----------------------------------------
Command python setup.py egg_info failed with error code 1 in /private/var/folders/wd/y0p85qd48xx992w8rkclf7mc8xdc8d/T/pip-build-glyph/pyparsing
Storing complete log in /Users/glyph/Library/Logs/pip.log

Discussion

  • bjodah
    bjodah
    2013-04-18

    I can confirm this "bug". Quite surprised it made it into pypi with this bug. A try except at this point with a useful error message describing the need to use 1.5.5 would be much appreciated.