#59 Syntax Error On setup.py

closed-wont-fix
nobody
None
5
2013-01-25
2013-01-25
Anonymous
No

Downloaded pyparsing-2.0.0.tar.gz.

On a linux box, tried to install via:

python setup.py install

but got this exception:

Traceback (most recent call last):
File "setup.py", line 9, in <module>
from pyparsing import __version__ as pyparsing_version
File "/tmp/pyparsing-2.0.0/pyparsing.py", line 629
nonlocal limit,foundArity
^
SyntaxError: invalid syntax

Discussion

  • Paul McGuire
    Paul McGuire
    2013-01-25

    • status: open --> closed-wont-fix
     
  • Paul McGuire
    Paul McGuire
    2013-01-25

    Pyparinng v2.x is written for Python 3 installations only. Since it appears you are running Python 2.x, the latest compatible pyparsing is version 1.5.7. You can easy_install this release using "easy_install pyparsing==1.5.7", or download the 1.5.7.tgz file.