2.0 Segfaults

Joe Hill
2004-09-29
2013-04-15
  • Joe Hill
    Joe Hill
    2004-09-29

    Builds and installs fine, but crashes out like so:

    joehill@node1:~>$pypanel
    /usr/lib/python2.3/site-packages/Xlib/display.py:30: DeprecationWarning: Non-ASCII character '\xf6' in file /usr/lib/python2.3/site-packages/Xlib/protocol/display.py on line 749, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
      import protocol.display
    Segmentation fault

    Needless to say, I have no idea what is being said on the page referenced in the error ;-)

     
    • Joe Hill
      Joe Hill
      2004-10-06

      Okay, I think I've narrowed it down. I believe my version of Imlib2 is out of date.

      The README states that version 1.1.1 is required. However, when I check on the Freshmeat project page for Imlib2, the latest version available is 1.0.6, which is what I have installed (on Mandrake 9.2...strangely enough, MDK 10.1 looks like it's shipping with 1.0.9...)

      I would really like to try to use the new version, so any tips or help greatly appreciated!

       
    • Jon Gelo
      Jon Gelo
      2004-10-06

      Joe,

      I tried sending you an email a few days ago about this.  You can ignore the DeprecationWarning from Python Xlib, it shouldn't have anything to do with the segfault.  The latest Imlib2 is v1.1.2, you can grab the source from the URL below and maybe give it a shot -

      http://sourceforge.net/project/showfiles.php?group_id=2

      Send me an email if you're still having troubles and maybe we can figure it out over a chat ..