Hi Ethan, thanks for your answer.

I have the following packages installed:
libode1: 2:0.11.1-3
libode-dev: 2:0.11.1-3 both of which seem to be the double-precision version.
python-pyode: 1.2.0-4+cvs20090320

I will try to build pyode from source, although I feel that may not be the issue.

Thanks again,
German

On Mon, Apr 11, 2011 at 2:13 PM, Ethan Glasser-Camp <glasse@cs.rpi.edu> wrote:
On 04/10/2011 05:55 PM, German Larrain M. wrote:
Hi. I'm a new user of pyode and I was trying to run the examples included the pythod-pyode-doc DEB package available in the Ubuntu repositories.

Tutorials 1 and 2 worked fine, but 3 fails every time I run it. The weird thing is that the error appears after the explosion, but not necessarily at the exact time. When it happens, the window closes and the following message is printed

It looks like this could be caused by a lot of different kinds of problems with the simulation itself.  It runs fine on my machine (10.10-based, 32 bit).  I wonder if maybe there's a problem with the .debs available in the Ubuntu repositories -- built with the wrong precision or something?  Could you try building pyode yourself?

Ethan




--
Germán Larrain