Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#35 Build fails

None
pending
None
5
2014-02-26
2014-02-21
Anista Rembw
No

I'm not able to intall pyMPI, I don't know what I'm doing wrong. Please, I need help, I'm desperate.Attached config result
This is my config command
./configure --prefix=/opt/pyMPI --with-includes=-I/usr/include/openmpi-x86_64/ --with-python=/usr/bin/python2.6

1 Attachments

Related

Bugs: #35

Discussion

  • Patrick Miller
    Patrick Miller
    2014-02-21

    • status: open --> pending
    • Group: -->
     
  • Patrick Miller
    Patrick Miller
    2014-02-21

    Config looks OK... Try a

    % make

    % sudo make install

     
  • Patrick Miller
    Patrick Miller
    2014-02-21

    • assigned_to: Patrick Miller
     
  • Patrick Miller
    Patrick Miller
    2014-02-21

    Hi Anista,

    Can you send me more info?

    Pat

    On Friday, February 21, 2014, Anista Rembw anistarembw@users.sf.net wrote:


    Status: open
    Created: Fri Feb 21, 2014 01:43 PM UTC by Anista Rembw
    Last Updated: Fri Feb 21, 2014 01:43 PM UTC
    Owner: nobody

    I'm not able to intall pyMPI, I don't know what I'm doing wrong. Please, I
    need help, I'm desperate.Attached config result
    This is my config command
    ./configure --prefix=/opt/pyMPI
    --with-includes=-I/usr/include/openmpi-x86_64/
    --with-python=/usr/bin/python2.6


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/pympi/bugs/35/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #35

    Attachments
  • Anista Rembw
    Anista Rembw
    2014-02-24

    Dear Patrick,
    Thanks for your reply. Attached config and make exit

     
    Attachments
  • Anista Rembw
    Anista Rembw
    2014-02-24

    and make exit file

    Thanks a lot in advanced

     
    Attachments
  • Anista Rembw
    Anista Rembw
    2014-02-24

    May I need some prerrequisites? what mpi version?

     
  • Anista Rembw
    Anista Rembw
    2014-02-24

    i've tried to install it in another machine, and I've found similar problems. Operating systes are Centos 6 and 5.
    What other doc should I send you to help you to help me?
    Thanks

     
    Attachments
  • Patrick Miller
    Patrick Miller
    2014-02-24

    The config errors seem to indicate that you are having some problems finding the Python 2.6 directories. If you have installed python, but not the python-devel package, you may need to do that.

    yum install python26-devel

    If you look in the config.log file, you will probably see the error, but it looks like it is just missing. Similarly, you may have to point at the mpicc (or at least have it in your path) to make sure that MPI will run. This explain most of the link errors and missing functions.

    Let me know how this goes. I can help get this working for you.

    Pat

     
  • Anista Rembw
    Anista Rembw
    2014-02-26

    Thank you Patrick, the problem was in a compilation line -lpython2.5 was missing.
    Everything works perfectly now.
    Thanks a lot!