On Thu, Apr 15, 2010 at 10:30 AM, Shiven Shandilya <shiven.shandilya@gmail.com> wrote:
Sorry to be knocking down APBS+PyMOL integration like this, but IMHO VASCo does a stellar job as far as integrating outside programs with PyMOL goes.


I initially wrote the PyMOL/APBS plugin for my own use and I now maintain/develop it as a community resource in my limited free time. Despite this, several hundred users (at least) have found it quite helpful in their research, and I've included many newer features based on their feedback. The plugin is certainly not perfect, and I don't mind people "knocking it down," but I appreciate it when that knocking down comes with constructive feedback.

Additionally, unlike VASCo, the PyMOL/APBS/PDB2PQR toolchain is provided as completely free and open source suite of programs. For many reasons, I believe that free and open source software is vital to to good science. I would strongly urge users to consider such issues before settling on a suite of software products, especially when you're already working with programs like PyMOL and APBS.

Cheers,

-Michael

 
Good luck!

Best,
Shiven



On Thu, Apr 15, 2010 at 12:01 AM, J. Fleming <moloch525@gmail.com> wrote:
Hi all,

 I've been trying to get APBS Tools and/or APBSTools2 running for a
few weeks now on multiple linux systems (RedHat and Fedora).  I've
Installed MALOC and APBS Tools.  I can start up Pymol through Phenix,
load a .pqr generated from a PDB2PQR server, start APBS Tools, set the
grid, but when I click on Run APBS I get: "ObjectMapLoadDXFile-Error:
Unable to open file!"

 If I use the "pymol generated PQR" option with my .pqr even though
it is a PDB2PQR server generated file APBS runs and states "X atoms
did not have properties assigned" and to either remove or fix the
atoms.  How can I fix them?  The "problem" residues are just regular
amino acids; no split confrimations etc.  I've also tried editing out
the PDBs chain name before converting to the PDB to PQR but that
didn't work.

Another things I've tried is using APBSTools 2 but it errors as soon
as I click "set grid" with: Error: 2 ... Attribute Error: elec_radius.

I really need to get this to work but I have no clue what to try next.

Thanks in advance for any thoughts.
-Jon

------------------------------------------------------------------------------
Download Intel&#174; Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
PyMOL-users mailing list (PyMOL-users@lists.sourceforge.net)
Info Page: https://lists.sourceforge.net/lists/listinfo/pymol-users
Archives: http://www.mail-archive.com/pymol-users@lists.sourceforge.net


------------------------------------------------------------------------------
Download Intel&#174; Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
PyMOL-users mailing list (PyMOL-users@lists.sourceforge.net)
Info Page: https://lists.sourceforge.net/lists/listinfo/pymol-users
Archives: http://www.mail-archive.com/pymol-users@lists.sourceforge.net



--
Michael Lerner, Ph.D.
IRTA Postdoctoral Fellow
Laboratory of Computational Biology NIH/NHLBI
5635 Fishers Lane, Room T909, MSC 9314
Rockville, MD 20852 (UPS/FedEx/Reality)
Bethesda MD 20892-9314 (USPS)