Hello Warren and pymol users,
Thanks for your help on what to fix to get r3d working in 0.98 with linux . .. but I still have one problem
How do I get a cgo.pyc to replace the cgo.pyc which has the bug in it. Sorry I dont understand anything about the inner workings of pyhton to replace the faulty cgo.pyc with a new fixed cgo.pyc and I use the static build provided by the website.

Also how do I get the list of ss elements assigned by util.ss
Thanks a lot for your help
Hari


On 6/13/05, Warren DeLano <warren@delanoscientific.com> wrote:
Hari,

This is an outright bug that I introduced when adding URL support for files.
You can change that one line of code in cgo.py from

   if (mode[0:1]=='r') and (string.find(fname,':')>1):

to

   if (string.find(fname,':')>1):

in order to solve the problem.

Cheers,
Warren

--
Warren L. DeLano, Ph.D.
Principal Scientist

. DeLano Scientific LLC
. 400 Oyster Point Blvd., Suite 213
. South San Francisco, CA 94080 USA
. Biz:(650)-872-0942  Tech:(650)-872-0834
. Fax:(650)-872-0273  Cell:(650)-346-1154
. mailto:warren@delsci.com


> -----Original Message-----
> From: pymol-users-admin@lists.sourceforge.net
> [mailto:pymol-users-admin@lists.sourceforge.net ] On Behalf Of
> hari jayaram
> Sent: Sunday, June 12, 2005 9:29 PM
> To: pymol-users@lists.sourceforge.net
> Subject: [PyMOL] pymol 0.98 and r3d input and getting sec
> structure assignments info
>
> Hello , I tried to open an r3d (raster3d) file in pymol
> version 0.98 and I get the following error
>
> Traceback (most recent call last):
>   File "/xtal2/pymol/modules/pymol/__init__.py", line 218, in
> exec_deferred
>     cmd.load(a,quiet=0)
>   File "/xtal2/pymol/modules/pymol/importing.py", line 549, in load
>     discrete,quiet,multiplex,zoom)
>   File "/xtal2/pymol/modules/pymol/cmd.py", line 755, in _load
>     obj = cgo.from_r3d(finfo)
>   File "/xtal2/pymol/modules/pymol/cgo.py", line 167, in from_r3d
>     if (mode[0:1]=='r') and (string.find(fname,':')>1):
> NameError: global name 'mode' is not defined
>
>
> The same exact r3d file opens up just fine on pymol 0.97. Is
> there something I am doing wrong or do I have to do something
> different to generate the file to work with 0.98.
>
> Any help will be greatly appreciated.
>
>  Also I was curious how to get pymol to spit out the
> secondary structure  assignments it useswhen one says assign
> sec structure in the gui. I know this was covered before but
> my googling skills are very dull today. So any help in
> getting info on the sec str assignments used by pymol for a
> particular model will also be greatly appreciated.
> Thanks
> hari
>
>