I was able to get rid of this error by installing  a new version of a Framework build for libpng from


I also switched to using the non homebrew version which I installed from source using "python setup.py install".

Now I can get the pymol window to show up and also import pymol inside python scripts without any error.
But as expected I cannot get the external GUI to work.

I tried installing Pmw and it complains about "tkinter" . Once I force it to use the Tkinter as tkinter

import sys,Tkinter
sys.modules["tkinter"] = Tkinter

Then the Pmw window does not show up and crashes.  

These are all old issues I am sure and I am hoping there is an easy fix. 

Sorry for using a 32 bit OSX machine running 10.6.8..but I recently resurrected it with a SSD and it actually runs faster than my Ubuntu Linux machine running 13.04.


On Fri, Aug 2, 2013 at 10:48 AM, hari jayaram <harijay@gmail.com> wrote:
Hi ,

I was able to use the latest homebrew pymol formula and install pymol after making sure that tcl-tk was installed with --enable-threads and --with-x11 and python was configured --with-brewed-tk

The pymol build proceeded to completion.

However when I launch pymol I get the following error ( see below)
Does anyone know what I am doing wrong.

I am (sadly still) using a 32 bit Mac OSX Snow Leopard 10.6.8 laptop .


hari-jayarams-macbook-pro-17:~ hari$ pymol
Traceback (most recent call last):
  File "/usr/local/Cellar/pymol/", line 185, in <module>
    import pymol
  File "/usr/local/Cellar/pymol/", line 499, in <module>
    from pymol import _cmd
ImportError: dlopen(/usr/local/Cellar/pymol/, 2): Symbol not found: _png_check_sig
  Referenced from: /usr/local/Cellar/pymol/
  Expected in: flat namespace