Hi Pascal,

What platform is this, and what version of pymol are you using. Also, it works if you type the command, but does it work if you run the script from the terminal? Is it possible that the editor inserted some (invisible) control characters?

Cheers,

Tsjerk


On Sat, Aug 31, 2013 at 3:16 PM, AUFFINGER Pascal (VIE) <p.auffinger@ibmc-cnrs.unistra.fr> wrote:
Hi,

I encountered a weird recent behavior of the command align.

In a script where I use the command
align (PO4 & name OP1+OP2+P), PO4_target

Where PO4 is a selection of O3',O5",P,OP1,OP2 atoms as well as PO4_target

When I run the script with "pymol -c" I get the following

PyMOL>align (PO4 & name OP1+OP2+P), PO4_target
 Match: read scoring matrix.
 Match: assigning 1 x 1 pairwise scores.
 MatchAlign: aligning residues (1 vs 1)...
 ExecutiveAlign: 2 atoms aligned.
 Executive: RMS =    0.023 (2 to 2 atoms)

The allignment is made only on 2 atoms. (OP1 and OP2)
While, it works if I introduce the command in the graphic window of pymol.

This worked perfectly with earlier versions of pymol.

Best,

Pascal
------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
PyMOL-users mailing list (PyMOL-users@lists.sourceforge.net)
Info Page: https://lists.sourceforge.net/lists/listinfo/pymol-users
Archives: http://www.mail-archive.com/pymol-users@lists.sourceforge.net



--
Tsjerk A. Wassenaar, Ph.D.