Hello everyone.  It has been a while since I posted here.  Apologies to the admins, I tried to subscribe again, and I forgot that I was already subscribed.

For some non-PyMol work, I was obligated to upgrade my operating system to Ubuntu Linux 11.10.  In fact, the specific reason that I had to upgrade was to get Python 2.7 as the default Python on my computer.

The Ubuntu Linux 11.10 repository listed PyMol 1.4.1, so I downloaded it and installed it.  When I attempted to launch PyMol, nothing happened.  So I visited the PyMol web page and found this:

"PyMOL v1.4+ do not run on SLED 10.2 due to a bug in Python 2.7 and Tcl/Tk."

http://www.pymol.org/support/platforms

Ouch.

I can't be the only person with this problem.  I also know that earlier installations of Ubuntu on my system had Python 2.4, 2.5, and 2.6 installed all at the same time, presumably for backwards compatibility with older components of the OS.  For some reason, when I upgraded this time, those earlier revisions of Python were removed.

So, would it be possible to "alternate-install" Python 2.6 on my current system, and then build PyMol on top of that?  Avoiding the management of package dependencies on two different Python versions was exactly the reason that I upgraded my OS.  But PyMol is essential to my work, I need to get it back.

Alternately, should I consider JyMol?  If JyMol would work for me, what would I lose by switching?

Finally, does anyone know what the specific bugs are in Python 2.7 and Tcl/Tk?  Has anyone submitted a bug fix request to the Python team?

Many thanks!