--- a/README
+++ b/README
@@ -38,7 +38,7 @@
 There is another branch of Pyke that is ready for Python3.x.  If you want
 Python3.x support, read this:
 
-    http://pyke.svn.sourceforge.net/viewvc/pyke/branches/pre_2to3/README-3.0
+    http://pyke.hg.sourceforge.net/hgweb/pyke/pre_2to3/file/e6e990a053fd/README-3.0
 
 Otherwise (if you want Pyke on Python2.5 or later 2.x release)...