#2 WebKit related crash after update

2.0
closed
tumagonx
2014-07-03
2014-07-01
Hunter Morris
No

After updating 3.10.2rev17 to 3.12.2rev4, I get this new error: "(python.exe:1036): Glib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy' is not installed". After acknowledging the dialog box, Python crashes. The missing component seems to be installed via the gsettings-desktop-schemas package but this is unavailable in the PyGObjectWin32 installer.

This is the shortest code segment to reproduce the error:

from gi.repository import WebKit
session = WebKit.get_default_session()
1 Attachments

Discussion

  • tumagonx
    tumagonx
    2014-07-01

    Thanks, proxy schemas was there but not its dependencies (part of gsettings-desktop) so it failed to compile. Next time the entire gsettings-desktop will be included by default, my concern is many of the schemas are linux (gnome deskop) specific I hope it doesn't affect Win32.

     
  • tumagonx
    tumagonx
    2014-07-03

    • status: open --> closed