Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

VariableError - can't expand variables

nobody
2006-08-24
2013-03-15
  • nobody
    nobody
    2006-08-24

    I get the following error when I attempt to expand a variable when I hit a breakpoint. I'm running Eclipse 3.1 on Linux.

    Error:  Error resolving variables Traceback (most recent call last):
      File "/opt/app/eclipse-3.1/plugins/org.python.pydev.debug_0.9.8.3/pysrc/pydevd.py", line 370, in doIt
        valDict = pydevd_vars.resolveCompoundVariable(self.thread, self.frame_id, self.scope, self.attributes)
      File "/opt/app/eclipse-3.1/plugins/org.python.pydev.debug_0.9.8.3/pysrc/pydevd_vars.py", line 136, in resolveCompoundVariable
        frame = findFrame(thread, frame_id)
      File "/opt/app/eclipse-3.1/plugins/org.python.pydev.debug_0.9.8.3/pysrc/pydevd_vars.py", line 131, in findFrame
        if curFrame == None : raise VariableError("findFrame: frame not found")
    VariableError: findFrame: frame not found

    This used to work fine but I lost my plugins an don't remember which version I had installed. I've tried several 0.9 version, 1.x seem to have other problems because I'm on  eclipse 3.1. Any ideas?
    What is the latest version that supports 3.1?
    Thanks
    Kim

     
    • Fabio Zadrozny
      Fabio Zadrozny
      2006-08-24

      Check http://pydev.sourceforge.net/features.html to know which features were incorporated in each release (and when the support for something was discontinued).

      Cheers,

      Fabio