Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Eclipse 3.6 + Pydev = numerous problems

Kyle
2010-09-08
2013-03-15
  • Kyle
    Kyle
    2010-09-08

    Sorry about the vague topic. I can't summarize the problem shortly.

    So I just installed Eclipse (with PHP) 3.6. Then I got Pydev installed by adding a new site with the http://pydev.org/updates. All seemed to go perfectly.

    However! When I go to Preferences->Pydev, I get this error: "Unable to create the selected preference page.
    Bad version number in .class file"

    This happens for any preference on the left having to do with Pydev.

    Also, if I try to New Project>Pydev>Pydev Project>Next, I get this error: "The selected wizard could not be started.
    Plug-in org.python.pydev was unable to load class org.python.pydev.ui.wizards.project.PythonProjectWizard.
    Bad version number in .class file"

    So Pydev appears not to work for me at all. What is the problem here?

    Thanks!

     
  • Kyle
    Kyle
    2010-09-08

    Oh, OS X 10.5, Java VM 1.5, Python 2.6, I do not have Jython installed or whatever (I'm not using it—I don't even know what it is). No Django. Build id: 20100617-1415 (Eclipse for PHP Developers)

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2010-09-08

    The problem is that pydev was not retroweaved properly to work with java 1.4 and 5 (as it's compiled with java 6).

    I've just pushed a new build fixing that, so, if you update to the latest it should work again (it's still version 1.6.2 as the only change was in the build process).

    Another option would be using a java 6 vm.

    Cheers,

    Fabio

     
  • Kyle
    Kyle
    2010-09-08

    Thank you very much. Will this break the next time Pydev is updated, or was this a bug that is now fixed for future upgrades?

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2010-09-08

    > Will this break the next time Pydev is updated, or was this a bug that is now fixed for future upgrades?

    As I'm too lazy, I've fixed it so that it works in all future upgrades and I don't have to fix it over and over again :)

    (it was a bug introduced in the process of adding the Django templates editor to the build process)

    Cheers,

    Fabio

     
  • gregj-in-va
    gregj-in-va
    2010-09-27

    My attempt to install Aptana PyDev for Eclipse plug-in using Aptana Studio within Eclipse
    fails with following message  :-(   :

    Cannot complete the install because one or more required items could not be found.
      Software being installed: PyDev Django Templates Editor 1.6.2.2010090812 (org.python.pydev.django_templates.feature.feature.group 1.6.2.2010090812)
      Missing requirement: Aptana Django Templates Editor 1.6.2.2010090812 (org.python.pydev.django_templates 1.6.2.2010090812) requires 'bundle com.aptana.editor.common 0.0.0' but it could not be found
      Cannot satisfy dependency:
        From: PyDev Django Templates Editor 1.6.2.2010090812 (org.python.pydev.django_templates.feature.feature.group 1.6.2.2010090812)
        To: org.python.pydev.django_templates

    Aptana Studio 2.0.5 Eclipse Plug-In, installed today
    Eclipse SDK 3.5.2, installed yesterday
    OpenJDK Java 6
    Ubuntu 10.04  the Lucid Lynx  with Gnome desktop
    HP Pavilion a1129n Media Center PC with 3400+ AMD Athlon 64 Processor and 1.5 GigaBytes RAM

    Seems like "adding the Django templates editor to the build process" isn't fully fixed yet.  ;-)

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2010-09-27

    Actually, if you get the latest Aptana Studio 3 versions, pydev (and the django templates editor) is already distributed with it (so, you shouldn't need to update pydev separately).

    Cheers,

    Fabio