Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#651 Code Coverage Results View broken

open
nobody
None
5
2008-08-19
2008-02-18
Håkan Johansson
No

I run a python file: "Run As -> Python Coverage" after having selected a good coverage dir.
I see that a .coverage file is generated in the '.metadata' directory.

The problem is that the results view says that there are not statistics for any of the files.

Notes:
* I cleared coverage information before the run.
* I refreshed coverage information after the run.
* The python project is not located in a subdirectory of the eclipse "home" dir. I am not sure if this is important or not, but it probably is since the
'.coverage' file was put in the eclipse home dir.
* This worked before the update of the coverage tool (except that it couldn't handle threads of course)

I have tried running a single file or all files in a directory. No difference.

Discussion

  • Fabio Zadrozny
    Fabio Zadrozny
    2008-06-15

    • status: open --> pending
     
  • Fabio Zadrozny
    Fabio Zadrozny
    2008-06-15

    Logged In: YES
    user_id=617340
    Originator: NO

    In which pydev version did this happen? Do you have something in your error log?

     
  • Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending --> closed
     
    • status: closed --> open
     
  • Logged In: YES
    user_id=1933533
    Originator: YES

    Sorry for not updating this bug. I have not had time until now.

    I tried it again today with the same result.
    PyDev: 1.3.15

    Nothing is written at all in the error log.

    I have a different layout than what is custom:
    ~/.eclipse/.metadata
    ~/work/myproject/pysrc

    I set 'pysrc' as coverage directory and run the tests that are located in there (Run as Python Coverage).

    This file is created when running the tests:
    ~/.eclipse/.metadata/.plugins/org.python.pydev.debug/.coverage

    From what I can see, the content of the file is correct (it contains the absolute pats to my files).

    My guess is that the "Code Coverage Results View" cannot find this file correctly because of my project layout.