#181 Variables view doesn't show letters in GNU/Linux

0.9.8.4
closed-wont-fix
debugger (210)
5
2006-01-17
2005-09-09
Unicyn
No

After upgrading to 0.9.8.1, I cannot see the letters
from the Variables view in debbuger. There is not
problem for copy and paste them to other place.

- System: Ubuntu Linux
- Eclipse: 3.1
- PyDev: 0.9.8.1
- Eclipse install location: $HOME/Desktop/Garapena/eclipse
- Project location where the bug appears: Every project

Discussion

1 2 > >> (Page 1 of 2)
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-09-11

    • status: open --> pending
     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-09-11

    Logged In: YES
    user_id=617340

    Hi, does this happen when using the java editor too?

    Pydev just uses the eclipse 'sandbox' for those kind of
    things, so, there is a good probability that this is an
    eclipse thing, and not a pydev thing... (I'm putting it in
    pending state until further info is provided).

    cheers,

    fabio

     
  • Unicyn
    Unicyn
    2005-09-11

    Python Debugger

     
    Attachments
  • Unicyn
    Unicyn
    2005-09-11

    Logged In: YES
    user_id=1342282

    Hi,
    There in not problem with java debbuger. In fact, the
    problem start after upgrading from 0.9.8 to 0.9.8.1. I
    attach two screenshot to show the problem.

     
  • Unicyn
    Unicyn
    2005-09-11

    • status: pending --> open
     
  • Unicyn
    Unicyn
    2005-09-11

    Java Debug

     
    Attachments
  • Unicyn
    Unicyn
    2005-09-14

    Logged In: YES
    user_id=1342282

    I have checked eclipse with a different distribution of
    linux and there is not problem, so the problem there must be
    in other place.

    Thanks.

     
  • Unicyn
    Unicyn
    2005-09-14

    • status: open --> closed
     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-09-14

    Logged In: YES
    user_id=617340

    Thanks for the follow-up... it was driving me crazy trying
    to reproduce this bug (which I was not able to do anyway...)

    Cheers,

    Fabio

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-09-14

    • status: closed --> closed-works-for-me
     
  • Unicyn
    Unicyn
    2005-11-03

    Logged In: YES
    user_id=1342282

    Hi,
    I am reopening the bug. I am in the 0.9.4 and the problem is
    still there. However, I found the following error when a
    breakpoint happens:
    !ENTRY org.python.pydev.debug 4 4 2005-11-03 23:16:25.117
    !MESSAGE Unexpected treadRun payload -1209061332 None

    Sadly, there is not exception stack. If the issue is not
    related, i will open another bug. Anyway, I can try to debug
    the plugin and get more information.

    Thanks

     
  • Unicyn
    Unicyn
    2005-11-03

    • status: closed-works-for-me --> open-works-for-me
     
  • Unicyn
    Unicyn
    2005-11-03

    Logged In: YES
    user_id=1342282

    1345584 is a duplicate of this bug

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-11-04

    Logged In: YES
    user_id=617340

    Ok, you mentioned in a previous post that it worked on
    version 0.9.8... Could you 'downgrade' pydev and see if this
    is really true?

    The post:
    http://sourceforge.net/tracker/index.php?func=detail&aid=1345584&group_id=85796&atid=577329
    mentioned:
    The only change that I recall making between when it last
    worked and now was the upgrade from Gnome 2.10 to 2.12.

    is this the same windows system you're using? Have you tried
    with some other (e.g. KDE or windowmaker) to see if it works
    there?

    Thanks,

    Fabio

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-11-04

    • milestone: 522109 --> 0.9.8.4
    • status: open-works-for-me --> open
     
  • Unicyn
    Unicyn
    2005-11-07

    Logged In: YES
    user_id=1342282

    Well, I tried to isolate* the problem and I think that it
    has something to do with the last version of pango.
    Tomorrow, I will get some screenshots and will send to gnome
    bugzilla.
    However, the only debugger in eclipse which shows this
    problem is pydev. Is there anything peculiar in the strings
    that are sent.

    *I opened one session with xterm and a window manager
    (metacity).
    1. open eclipse. Debug one python program and it works fine.
    2. Execute "gnome-theme-manager".
    3. open eclipse. Debug the same program and the problem is
    there.

    I repeated these steps with 0.9.8.4 and 0.9.8.1 with same
    output. There is no problem with kde (3.4.1).

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2005-11-08

    Logged In: YES
    user_id=617340

    Ok, so, it seems bound to gnome right? Maybe it is worth
    reporting it in the eclipse bug-tracker too...

    Have you tried it with any other debugger instead of the one
    provided by pydev and java (there are many non-standard
    things in the java debugger, so, trying with some other one
    that has a structure that is more alike the 'standard'
    structure, such as the ruby plugin might be a good idea too).

    As for the strings sent, I don't think there is anything
    peculiar about them...

    Cheers,

    Fabio

     
  • Logged In: NO

    Hey every body. I have the same problem.
    I have the same set up ( basically Gnome + ubuntu + eclipse 3.1)

    Every version of pydev has done this to me.
    The good news is there is a work around.
    In gnome font prefs, set your DPI to less that 76.
    it works on the fly.

    Hope that helps
    ~~Buzzco ( http://buzzco.org )

     
  • Doug
    Doug
    2005-12-19

    Logged In: YES
    user_id=1408205

    Hi Fabio,

    I'm new to Eclipse & PyDev, but I really like what I see. I
    have this bug, too (FreeBSD 6/Gnome 2.12/Eclipse 3.1.1/PyDev
    0.9.8.5). The fix (Gnome font rendering resolution <=75
    dpi) works for me, too (but my screen makes that difficult
    to read!).

    It seems that all font rendering in Eclipse uses this
    setting (menus, tabs, buttons, dialogs, editors, etc.).
    Another bug with the editor panes means their font won't
    change unless the canvas needs to be regenerated. In any
    case, I've only noticed this bug w/text in the Variables
    view: all other text displays regardless of the DPI.

    I tried debugging a simple project in Java and the problem
    is the same there, so it is probably an Eclipse/Gnome bug
    and doesn't seem to be PyDev specific. I've searched
    through a couple hundred bug summaries on Eclipse.org's
    Bugzilla to find the bug but haven't located it. I'm not
    familiar with the project's component terminology, so it's a
    slow process.

    Thanks,
    Doug

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2006-01-17

    Logged In: YES
    user_id=617340

    Ok, I'm closing this bug and adding a comment in the FAQ for
    it.

    Cheers,

    Fabio

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2006-01-17

    • status: open --> closed-wont-fix
     
  • arthur_kalm
    arthur_kalm
    2006-03-08

    Logged In: YES
    user_id=1237449

    Hi I'm running Kubuntu Linux with KDE 3.5.1 and Eclipse
    (GTK) 3.1.1 (from the website not from the distro) with
    PyDev 1.0.2. I am having the same problem and the work
    around seems to work when I use GNOME. However, since I am a
    KDE user I was wondering if anyone has figured out how to
    solve this problem on KDE?

    Thank you for your time,
    Arthur

     
  • Unicyn
    Unicyn
    2006-03-11

    Logged In: YES
    user_id=1342282

    Fixed in Gnome 2.14 RC.

     
1 2 > >> (Page 1 of 2)