#31 does not install with curl-config greater than 7.19.5

v1.0_(example)
closed-fixed
Oleg Pudeyev
None
5
2013-09-26
2013-02-11
Anonymous
No

pycurl as distributed on pypy tries to pass the '--static-libs' argument to curl-config which is an option not understood in old versions of curl-config (like used on rhel6). This causes the package installation to fail silently as gcc incorrectly interprets the error output from curl-config. The package appears to install but can not be imported in the python environment afterwards due to not being built.

See these two articles for more info:
http://yz.mit.edu/wp/cute-silent-failure-building-pycurl/
http://stackoverflow.com/questions/7391638/pycurl-installed-but-not-found/7400218#7400218

Discussion

  • Oleg Pudeyev
    Oleg Pudeyev
    2013-09-26

    This bug was fixed in 2010 but the fix only was included in 7.19.0.1 release made recently.

    https://sourceforge.net/p/pycurl/bugs/15/

     
  • Oleg Pudeyev
    Oleg Pudeyev
    2013-09-26

    • status: open --> closed-fixed
    • assigned_to: Oleg Pudeyev
    • Group: --> v1.0_(example)